# CVE-2025-53107: @cyanheads/git-mcp-server vulnerable to command injection in several tools

> Attackers can execute arbitrary system commands via unsanitized input in the Git MCP server, leading to remote code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jul 2025
- **Updated:** 1 Jul 2025
- **Also known as:** GHSA-3q26-f695-pp76

## What is CVE-2025-53107?

CVE-2025-53107 is a high-severity command injection vulnerability in cyanheads git-mcp-server, published on 1 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

@cyanheads/git-mcp-server is an MCP server designed to interact with Git repositories. Prior to version 2.1.5, there is a command injection vulnerability caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). An MCP Client can be instructed to execute additional actions for example via indirect prompt injection when asked to read git logs. This issue has been patched in version 2.1.5.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-53107?

2 open source packages ship an affected version, including @cyanheads/git-mcp-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cyanheads/git-mcp-server` | npm | All versions | 2.1.5 |
| `@cyanheads/git-mcp-server` | npm | All versions | 2.1.5 |

## How do I fix CVE-2025-53107?

Upgrade @cyanheads/git-mcp-server to 2.1.5 or later.

## Is CVE-2025-53107 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53107 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53107 and fix it if it is affected.

What it is: CVE-2025-53107 is a high-severity command injection vulnerability in cyanheads git-mcp-server, published on 1 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53107 exists.

Affected packages and fixed versions:
- @cyanheads/git-mcp-server (npm): affected all versions; fixed in 2.1.5
- @cyanheads/git-mcp-server (npm): affected all versions; fixed in 2.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53107/ (Markdown: https://insights.sbomify.com/CVE-2025-53107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53107
- OSV: https://osv.dev/vulnerability/CVE-2025-53107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53107/
Summaries are generated and may contain mistakes; the official description above is the record.
