CVE-2025-53110 Model Context Protocol Servers Vulnerable to Path Validation Bypass via Colliding Path Prefix
Attackers can bypass path validation to access unintended files in the Model Context Protocol filesystem server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-53110?
CVE-2025-53110 is a high-severity path traversal vulnerability in modelcontextprotocol servers, published on 2 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Model Context Protocol Servers is a collection of reference implementations for the model context protocol (MCP). Versions of Filesystem prior to 0.6.4 or 2025.7.01 could allow access to unintended files in cases where the prefix matches an allowed directory. Users are advised to upgrade to 0.6.4 or 2025.7.01 resolve.
Weakness: CWE-22
Which versions are affected by CVE-2025-53110?
4 open source packages ship an affected version, including @modelcontextprotocol/server-filesystem.
| Package | Affected | Fixed in |
|---|---|---|
@modelcontextprotocol/server-filesystem npm | All versions to 0.6.2 | None |
@modelcontextprotocol/server-filesystem npm | All versions to 0.6.2 | None |
@modelcontextprotocol/server-filesystem npm | From 2025.1.14 | 2025.7.1 |
@modelcontextprotocol/server-filesystem npm | From 2025.1.14 | 2025.7.1 |
How do I fix CVE-2025-53110?
Upgrade @modelcontextprotocol/server-filesystem to 2025.7.1 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-53110 being exploited?
There is no known exploitation of CVE-2025-53110 in the wild and no public exploit code.
Sources
Also known as GHSA-hc55-p739-j48w.