CVE-2025-53112 GLPI's incomprehensive permission checks can lead to data removal from allowed users
Attackers with limited permissions can remove specific resources due to missing permission checks in GLPI.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-53112?
CVE-2025-53112 is a medium-severity missing authorization vulnerability in Glpi-Project Glpi, published on 30 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
GLPI is a Free Asset and IT Management Software package, that provides ITIL Service Desk features, licenses tracking and software auditing. In versions 9.1.0 through 10.0.18, a lack of permission checks can result in unauthorized removal of some specific resources. This is fixed in version 10.0.19.
Which versions are affected by CVE-2025-53112?
It affects 1 product.
Products include Glpi-Project Glpi.
How do I fix CVE-2025-53112?
No fix has been published for CVE-2025-53112 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-53112 being exploited?
There is no known exploitation of CVE-2025-53112 in the wild and no public exploit code.
Other vulnerabilities in Glpi-Project Glpi
- CVE-2022-35914 Teclib GLPI Remote Code Execution
- CVE-2023-42802 GLPI vulnerable to unallowed PHP script execution
- CVE-2023-28849 GLPI vulnerable to SQL injection and Stored XSS via inventory agent request
- CVE-2022-35947 SQL injection in GLPI
- CVE-2022-31056 SQL injection with _actor parameter in GLPI
Sources
Also known as GHSA-rp7w-6343-3m2r, UBUNTU-CVE-2025-53112.