CVE-2025-53114 CometD has acknowledgement extension out of memory
A malicious client can cause an OutOfMemoryError in CometD by exploiting the acknowledgement extension, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-53114?
CVE-2025-53114 is a high-severity denial of service vulnerability in cometd, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
CometD is a scalable comet implementation for web messaging. In versions 5.0.0 through 5.0.22, 6.0.0 through 6.0.18, 7.0.0 through 7.0.18, and 8.0.0 through 8.0.8, bad clients that always send a fixed batch value when the server is using the acknowledgement extension may cause the unacknowledged message queue to grow indefinitely, eventually causing an `OutOfMemoryError`. Versions 5.0.23, 6.0.19, 7.0.19, and 8.0.9 patch the issue. As a workaround, disable the acknowledgement extension.
Weakness: CWE-400
Which versions are affected by CVE-2025-53114?
8 open source packages ship an affected version, including org.cometd.java:cometd-java-server-common.
| Package | Affected | Fixed in |
|---|---|---|
org.cometd.java:cometd-java-server-common Maven | From 5.0.0 | 5.0.23 |
org.cometd.java:cometd-java-server-common Maven | From 5.0.0 | 5.0.23 |
org.cometd.java:cometd-java-server-common Maven | From 6.0.0 | 6.0.19 |
org.cometd.java:cometd-java-server-common Maven | From 6.0.0 | 6.0.19 |
org.cometd.java:cometd-java-server-common Maven | From 7.0.0 | 7.0.19 |
org.cometd.java:cometd-java-server-common Maven | From 7.0.0 | 7.0.19 |
2 more packages
org.cometd.java:cometd-java-server-common Maven | From 8.0.0 | 8.0.9 |
org.cometd.java:cometd-java-server-common Maven | From 8.0.0 | 8.0.9 |
How do I fix CVE-2025-53114?
Upgrade org.cometd.java:cometd-java-server-common to a fixed version for your release line: 5.0.23, 6.0.19, 7.0.19 or 8.0.9.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-53114 being exploited?
There is no known exploitation of CVE-2025-53114 in the wild and no public exploit code.
Sources
Also known as GHSA-cqgj-h8vf-4w59.