{"answers":{"affected":"8 open source packages ship an affected version, including org.cometd.java:cometd-java-server-common.","exploited":"There is no known exploitation of CVE-2025-53114 in the wild and no public exploit code.","fix":"Upgrade org.cometd.java:cometd-java-server-common to a fixed version for your release line: 5.0.23, 6.0.19, 7.0.19 or 8.0.9.","what":"CVE-2025-53114 is a high-severity denial of service vulnerability in cometd, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53114 and fix it if it is affected.\n\nWhat it is: CVE-2025-53114 is a high-severity denial of service vulnerability in cometd, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-53114 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.cometd.java:cometd-java-server-common (Maven): affected from 5.0.0; fixed in 5.0.23\n- org.cometd.java:cometd-java-server-common (Maven): affected from 5.0.0; fixed in 5.0.23\n- org.cometd.java:cometd-java-server-common (Maven): affected from 6.0.0; fixed in 6.0.19\n- org.cometd.java:cometd-java-server-common (Maven): affected from 6.0.0; fixed in 6.0.19\n- org.cometd.java:cometd-java-server-common (Maven): affected from 7.0.0; fixed in 7.0.19\n- org.cometd.java:cometd-java-server-common (Maven): affected from 7.0.0; fixed in 7.0.19\n- org.cometd.java:cometd-java-server-common (Maven): affected from 8.0.0; fixed in 8.0.9\n- org.cometd.java:cometd-java-server-common (Maven): affected from 8.0.0; fixed in 8.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53114/ (Markdown: https://insights.sbomify.com/CVE-2025-53114/index.md)","id":"CVE-2025-53114","markdown":"https://insights.sbomify.com/CVE-2025-53114/index.md","name":"CVE-2025-53114","record":{"aliases":["GHSA-cqgj-h8vf-4w59"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"CometD web messaging library","requires_auth":"none","summary":"A malicious client can cause an OutOfMemoryError in CometD by exploiting the acknowledgement extension, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"CometD is a scalable comet implementation for web messaging. In versions 5.0.0 through 5.0.22, 6.0.0 through 6.0.18, 7.0.0 through 7.0.18, and 8.0.0 through 8.0.8, bad clients that always send a fixed batch value when the server is using the acknowledgement extension may cause the unacknowledged message queue to grow indefinitely, eventually causing an `OutOfMemoryError`. Versions 5.0.23, 6.0.19, 7.0.19, and 8.0.9 patch the issue. As a workaround, disable the acknowledgement extension.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CometD has acknowledgement extension out of memory","id":"CVE-2025-53114","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":8,"n_references":6,"next":{"headline":"Securden Unified PAM Authentication Bypass","id":"CVE-2025-53118"},"packages":[{"ecosystem":"Maven","fixed":["5.0.23"],"introduced":["5.0.0"],"last_affected":[],"package":"org.cometd.java:cometd-java-server-common","purl":null,"source":"GHSA-cqgj-h8vf-4w59"},{"ecosystem":"Maven","fixed":["5.0.23"],"introduced":["5.0.0"],"last_affected":[],"package":"org.cometd.java:cometd-java-server-common","purl":"pkg:maven/org.cometd.java/cometd-java-server-common","source":"GHSA-cqgj-h8vf-4w59"},{"ecosystem":"Maven","fixed":["6.0.19"],"introduced":["6.0.0"],"last_affected":[],"package":"org.cometd.java:cometd-java-server-common","purl":null,"source":"GHSA-cqgj-h8vf-4w59"},{"ecosystem":"Maven","fixed":["6.0.19"],"introduced":["6.0.0"],"last_affected":[],"package":"org.cometd.java:cometd-java-server-common","purl":"pkg:maven/org.cometd.java/cometd-java-server-common","source":"GHSA-cqgj-h8vf-4w59"},{"ecosystem":"Maven","fixed":["7.0.19"],"introduced":["7.0.0"],"last_affected":[],"package":"org.cometd.java:cometd-java-server-common","purl":null,"source":"GHSA-cqgj-h8vf-4w59"},{"ecosystem":"Maven","fixed":["7.0.19"],"introduced":["7.0.0"],"last_affected":[],"package":"org.cometd.java:cometd-java-server-common","purl":"pkg:maven/org.cometd.java/cometd-java-server-common","source":"GHSA-cqgj-h8vf-4w59"},{"ecosystem":"Maven","fixed":["8.0.9"],"introduced":["8.0.0"],"last_affected":[],"package":"org.cometd.java:cometd-java-server-common","purl":null,"source":"GHSA-cqgj-h8vf-4w59"},{"ecosystem":"Maven","fixed":["8.0.9"],"introduced":["8.0.0"],"last_affected":[],"package":"org.cometd.java:cometd-java-server-common","purl":"pkg:maven/org.cometd.java/cometd-java-server-common","source":"GHSA-cqgj-h8vf-4w59"}],"prev":{"headline":"GLPI technicians can access unauthorized information through external links","id":"CVE-2025-53113"},"products":["cometd"],"published":"2026-06-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-18","vendors":["cometd"]},"summary":"A malicious client can cause an OutOfMemoryError in CometD by exploiting the acknowledgement extension, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2025-53114/"}