# CVE-2025-53114: CometD has acknowledgement extension out of memory

> A malicious client can cause an OutOfMemoryError in CometD by exploiting the acknowledgement extension, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-cqgj-h8vf-4w59

## What is CVE-2025-53114?

CVE-2025-53114 is a high-severity denial of service vulnerability in cometd, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CometD is a scalable comet implementation for web messaging. In versions 5.0.0 through 5.0.22, 6.0.0 through 6.0.18, 7.0.0 through 7.0.18, and 8.0.0 through 8.0.8, bad clients that always send a fixed batch value when the server is using the acknowledgement extension may cause the unacknowledged message queue to grow indefinitely, eventually causing an `OutOfMemoryError`. Versions 5.0.23, 6.0.19, 7.0.19, and 8.0.9 patch the issue. As a workaround, disable the acknowledgement extension.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-53114?

8 open source packages ship an affected version, including org.cometd.java:cometd-java-server-common.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cometd.java:cometd-java-server-common` | Maven | From 5.0.0 | 5.0.23 |
| `org.cometd.java:cometd-java-server-common` | Maven | From 5.0.0 | 5.0.23 |
| `org.cometd.java:cometd-java-server-common` | Maven | From 6.0.0 | 6.0.19 |
| `org.cometd.java:cometd-java-server-common` | Maven | From 6.0.0 | 6.0.19 |
| `org.cometd.java:cometd-java-server-common` | Maven | From 7.0.0 | 7.0.19 |
| `org.cometd.java:cometd-java-server-common` | Maven | From 7.0.0 | 7.0.19 |
| `org.cometd.java:cometd-java-server-common` | Maven | From 8.0.0 | 8.0.9 |
| `org.cometd.java:cometd-java-server-common` | Maven | From 8.0.0 | 8.0.9 |

## How do I fix CVE-2025-53114?

Upgrade org.cometd.java:cometd-java-server-common to a fixed version for your release line: 5.0.23, 6.0.19, 7.0.19 or 8.0.9.

## Is CVE-2025-53114 being exploited?

There is no known exploitation of CVE-2025-53114 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53114 and fix it if it is affected.

What it is: CVE-2025-53114 is a high-severity denial of service vulnerability in cometd, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53114 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cometd.java:cometd-java-server-common (Maven): affected from 5.0.0; fixed in 5.0.23
- org.cometd.java:cometd-java-server-common (Maven): affected from 5.0.0; fixed in 5.0.23
- org.cometd.java:cometd-java-server-common (Maven): affected from 6.0.0; fixed in 6.0.19
- org.cometd.java:cometd-java-server-common (Maven): affected from 6.0.0; fixed in 6.0.19
- org.cometd.java:cometd-java-server-common (Maven): affected from 7.0.0; fixed in 7.0.19
- org.cometd.java:cometd-java-server-common (Maven): affected from 7.0.0; fixed in 7.0.19
- org.cometd.java:cometd-java-server-common (Maven): affected from 8.0.0; fixed in 8.0.9
- org.cometd.java:cometd-java-server-common (Maven): affected from 8.0.0; fixed in 8.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53114/ (Markdown: https://insights.sbomify.com/CVE-2025-53114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53114
- OSV: https://osv.dev/vulnerability/CVE-2025-53114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53114/
Summaries are generated and may contain mistakes; the official description above is the record.
