# CVE-2025-53121: Stored XSS in multiple 33.0.8files in opennms/opennms

> Attackers can inject malicious scripts via unsanitized parameters in OpenNMS Horizon, potentially leading to code execution or account takeover.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:A/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 26 Jun 2025
- **Updated:** 26 Jun 2025
- **Also known as:** GHSA-cjcp-5fq7-pgm2

## What is CVE-2025-53121?

CVE-2025-53121 is a medium-severity cross-site scripting vulnerability in The OpenNMS Group Horizon, published on 26 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Multiple stored XSS were found on different nodes with unsanitized parameters in OpenMNS Horizon 33.0.8 and versions earlier than 33.1.6 on multiple platforms that allow an attacker to store on database and then inject HTML and/or Javascript on the page. The solution is to upgrade to Horizon 33.1.6, 33.1.7 or Meridian 2024.2.6, 2024.2.7 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Fábio Tomé for reporting this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-53121?


## How do I fix CVE-2025-53121?

No fix has been published for CVE-2025-53121 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-53121 being exploited?

There is no known exploitation of CVE-2025-53121 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53121 and fix it if it is affected.

What it is: CVE-2025-53121 is a medium-severity cross-site scripting vulnerability in The OpenNMS Group Horizon, published on 26 Jun 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-53121 in the wild and no public exploit code.

Affected product: The OpenNMS Group Horizon. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53121/ (Markdown: https://insights.sbomify.com/CVE-2025-53121/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53121
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53121
- OSV: https://osv.dev/vulnerability/CVE-2025-53121

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53121/
Summaries are generated and may contain mistakes; the official description above is the record.
