# CVE-2025-53122: SQLi in OpenNMS Horizon and Meridian

> Attackers can execute arbitrary SQL commands in OpenNMS Horizon and Meridian, potentially reading or modifying data.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Jun 2025
- **Updated:** 26 Jun 2025
- **Also known as:** GHSA-gf77-whxf-fmrr

## What is CVE-2025-53122?

CVE-2025-53122 is a medium-severity SQL injection vulnerability in The OpenNMS Group Horizon, published on 26 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in OpenNMS Horizon and Meridian applications allows SQL Injection. 

Users
should upgrade to Meridian 2024.2.6 or newer, or Horizon 33.16 or newer. Meridian and
Horizon installation instructions state that they are intended for installation
within an organization's private networks and should not be directly accessible
from the Internet.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-53122?


## How do I fix CVE-2025-53122?

No fix has been published for CVE-2025-53122 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-53122 being exploited?

There is no known exploitation of CVE-2025-53122 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53122 and fix it if it is affected.

What it is: CVE-2025-53122 is a medium-severity SQL injection vulnerability in The OpenNMS Group Horizon, published on 26 Jun 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53122 in the wild and no public exploit code.

Affected product: The OpenNMS Group Horizon. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53122/ (Markdown: https://insights.sbomify.com/CVE-2025-53122/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53122
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53122
- OSV: https://osv.dev/vulnerability/CVE-2025-53122

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53122/
Summaries are generated and may contain mistakes; the official description above is the record.
