{"answers":{"affected":"3 open source packages ship an affected version, including nicegui.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53354 exists.","fix":"Upgrade nicegui to 3.0.0 or later.","what":"CVE-2025-53354 is a medium-severity cross-site scripting vulnerability in zauberzeug nicegui, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-53354 and fix it if it is affected.\n\nWhat it is: CVE-2025-53354 is a medium-severity cross-site scripting vulnerability in zauberzeug nicegui, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53354 exists.\n\nAffected packages and fixed versions:\n- nicegui (PyPI): affected all versions; fixed in 3.0.0\n- nicegui (PyPI): affected all versions; fixed in 3.0.0\n- nicegui (PyPI): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53354/ (Markdown: https://insights.sbomify.com/CVE-2025-53354/index.md)","id":"CVE-2025-53354","markdown":"https://insights.sbomify.com/CVE-2025-53354/index.md","name":"CVE-2025-53354","record":{"aliases":["GHSA-8c95-hpq2-w46f","PYSEC-2026-1699"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python UI framework","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in users' browsers via unescaped input in NiceGUI applications using ui.html().","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"NiceGUI is a Python-based UI framework. Versions 2.24.2 and below are at risk for Cross-Site Scripting (XSS) when developers render unescaped user input into the DOM using ui.html(). NiceGUI did not enforce HTML or JavaScript sanitization, so applications that directly combine components like ui.input() with ui.html() or  ui.chat_message with HTML content without escaping may allow attackers to execute arbitrary JavaScript in the user’s browser. Applications that do not pass untrusted input into ui.html() are not affected. This issue is fixed in version 3.0.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"NiceGUI is vulnerable to Reflected XSS attack","id":"CVE-2025-53354","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"mcp-server-kubernetes vulnerable to command injection in several tools","id":"CVE-2025-53355"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"nicegui","purl":null,"source":"GHSA-8c95-hpq2-w46f"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"nicegui","purl":"pkg:pypi/nicegui","source":"GHSA-8c95-hpq2-w46f"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"nicegui","purl":"pkg:pypi/nicegui","source":"PYSEC-2026-1699"}],"prev":{"headline":"WordPress Grid Plus plugin \u003c= 3.3 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2025-53352"},"products":["nicegui"],"published":"2025-10-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-03","vendors":["zauberzeug"]},"summary":"Attackers can execute arbitrary JavaScript in users' browsers via unescaped input in NiceGUI applications using ui.html().","url":"https://insights.sbomify.com/CVE-2025-53354/"}