# CVE-2025-53354: NiceGUI is vulnerable to Reflected XSS attack

> Attackers can execute arbitrary JavaScript in users' browsers via unescaped input in NiceGUI applications using ui.html().

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Oct 2025
- **Updated:** 3 Oct 2025
- **Also known as:** GHSA-8c95-hpq2-w46f, PYSEC-2026-1699

## What is CVE-2025-53354?

CVE-2025-53354 is a medium-severity cross-site scripting vulnerability in zauberzeug nicegui, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NiceGUI is a Python-based UI framework. Versions 2.24.2 and below are at risk for Cross-Site Scripting (XSS) when developers render unescaped user input into the DOM using ui.html(). NiceGUI did not enforce HTML or JavaScript sanitization, so applications that directly combine components like ui.input() with ui.html() or  ui.chat_message with HTML content without escaping may allow attackers to execute arbitrary JavaScript in the user’s browser. Applications that do not pass untrusted input into ui.html() are not affected. This issue is fixed in version 3.0.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-53354?

3 open source packages ship an affected version, including nicegui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nicegui` | PyPI | All versions | 3.0.0 |
| `nicegui` | PyPI | All versions | 3.0.0 |
| `nicegui` | PyPI | All versions | 3.0.0 |

## How do I fix CVE-2025-53354?

Upgrade nicegui to 3.0.0 or later.

## Is CVE-2025-53354 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53354 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53354 and fix it if it is affected.

What it is: CVE-2025-53354 is a medium-severity cross-site scripting vulnerability in zauberzeug nicegui, published on 3 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53354 exists.

Affected packages and fixed versions:
- nicegui (PyPI): affected all versions; fixed in 3.0.0
- nicegui (PyPI): affected all versions; fixed in 3.0.0
- nicegui (PyPI): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53354/ (Markdown: https://insights.sbomify.com/CVE-2025-53354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53354
- OSV: https://osv.dev/vulnerability/CVE-2025-53354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53354/
Summaries are generated and may contain mistakes; the official description above is the record.
