{"answers":{"affected":"2 open source packages ship an affected version, including mcp-server-kubernetes.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53355 exists.","fix":"Upgrade mcp-server-kubernetes to 2.5.0 or later.","what":"CVE-2025-53355 is a high-severity command injection vulnerability in Flux159 mcp-server-kubernetes, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-53355 and fix it if it is affected.\n\nWhat it is: CVE-2025-53355 is a high-severity command injection vulnerability in Flux159 mcp-server-kubernetes, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53355 exists.\n\nAffected packages and fixed versions:\n- mcp-server-kubernetes (npm): affected all versions; fixed in 2.5.0\n- mcp-server-kubernetes (npm): affected all versions; fixed in 2.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53355/ (Markdown: https://insights.sbomify.com/CVE-2025-53355/index.md)","id":"CVE-2025-53355","markdown":"https://insights.sbomify.com/CVE-2025-53355/index.md","name":"CVE-2025-53355","record":{"aliases":["GHSA-gjv4-ghm7-q58q"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes MCP server","requires_auth":"none","summary":"Attackers can inject arbitrary system commands via unsanitized inputs in the Kubernetes MCP server, leading to remote code execution.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"MCP Server Kubernetes is an MCP Server that can connect to a Kubernetes cluster and manage it. A command injection vulnerability exists in the mcp-server-kubernetes MCP Server. The vulnerability is caused by the unsanitized use of input parameters within a call to child_process.execSync, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. This vulnerability is fixed in 2.5.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"mcp-server-kubernetes vulnerable to command injection in several tools","id":"CVE-2025-53355","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"GLPI permits reservation modification by unauthorized users","id":"CVE-2025-53357"},"packages":[{"ecosystem":"npm","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"mcp-server-kubernetes","purl":null,"source":"GHSA-gjv4-ghm7-q58q"},{"ecosystem":"npm","fixed":["2.5.0"],"introduced":["0"],"last_affected":[],"package":"mcp-server-kubernetes","purl":"pkg:npm/mcp-server-kubernetes","source":"GHSA-gjv4-ghm7-q58q"}],"prev":{"headline":"NiceGUI is vulnerable to Reflected XSS attack","id":"CVE-2025-53354"},"products":["mcp-server-kubernetes"],"published":"2025-07-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-09","vendors":["Flux159"]},"summary":"Attackers can inject arbitrary system commands via unsanitized inputs in the Kubernetes MCP server, leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2025-53355/"}