# CVE-2025-53355: mcp-server-kubernetes vulnerable to command injection in several tools

> Attackers can inject arbitrary system commands via unsanitized inputs in the Kubernetes MCP server, leading to remote code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2025
- **Updated:** 9 Jul 2025
- **Also known as:** GHSA-gjv4-ghm7-q58q

## What is CVE-2025-53355?

CVE-2025-53355 is a high-severity command injection vulnerability in Flux159 mcp-server-kubernetes, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

MCP Server Kubernetes is an MCP Server that can connect to a Kubernetes cluster and manage it. A command injection vulnerability exists in the mcp-server-kubernetes MCP Server. The vulnerability is caused by the unsanitized use of input parameters within a call to child_process.execSync, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. This vulnerability is fixed in 2.5.0.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-53355?

2 open source packages ship an affected version, including mcp-server-kubernetes.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-server-kubernetes` | npm | All versions | 2.5.0 |
| `mcp-server-kubernetes` | npm | All versions | 2.5.0 |

## How do I fix CVE-2025-53355?

Upgrade mcp-server-kubernetes to 2.5.0 or later.

## Is CVE-2025-53355 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53355 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53355 and fix it if it is affected.

What it is: CVE-2025-53355 is a high-severity command injection vulnerability in Flux159 mcp-server-kubernetes, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53355 exists.

Affected packages and fixed versions:
- mcp-server-kubernetes (npm): affected all versions; fixed in 2.5.0
- mcp-server-kubernetes (npm): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53355/ (Markdown: https://insights.sbomify.com/CVE-2025-53355/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53355
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53355
- OSV: https://osv.dev/vulnerability/CVE-2025-53355

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53355/
Summaries are generated and may contain mistakes; the official description above is the record.
