{"answers":{"affected":"2 open source packages ship an affected version, including ethereum.","exploited":"There is no known exploitation of CVE-2025-53359 in the wild and no public exploit code.","fix":"Upgrade ethereum to 0.18.0 or later.","what":"CVE-2025-53359 is a medium-severity vulnerability in rust-ethereum ethereum, published on 2 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53359 and fix it if it is affected.\n\nWhat it is: CVE-2025-53359 is a medium-severity vulnerability in rust-ethereum ethereum, published on 2 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-53359 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ethereum (crates.io): affected all versions; fixed in 0.18.0\n- ethereum (crates.io): affected all versions; fixed in 0.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53359/ (Markdown: https://insights.sbomify.com/CVE-2025-53359/index.md)","id":"CVE-2025-53359","markdown":"https://insights.sbomify.com/CVE-2025-53359/index.md","name":"CVE-2025-53359","record":{"aliases":["GHSA-3w94-vq2x-v5wr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust Ethereum library","requires_auth":"none","summary":"The Rust ethereum library fails to check signature malleability for newer transaction types, potentially causing specification deviations in blockchain interactions.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-754","name":"Improper Check for Unusual or Exceptional Conditions"}],"description":"ethereum is a common ethereum structs for Rust. Prior to ethereum crate v0.18.0, signature malleability (according to EIP-2) was only checked for \"legacy\" transactions, but not for EIP-2930, EIP-1559 and EIP-7702 transactions. This is a specification deviation. The signature malleability itself is not a security issue and not as high of a risk if the ethereum crate is used on a single-implementation blockchain. This issue has been patched in version v0.18.0. A workaround for this issue involves manually checking transaction malleability outside of the crate, however upgrading is recommended.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ethereum does not check transaction malleability for EIP-2930, EIP-1559 and EIP-7702 transactions","id":"CVE-2025-53359","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"other","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"pluginsGLPI's Database Inventory Plugin allows any authenticated user to send agent requests","id":"CVE-2025-53360"},"packages":[{"ecosystem":"crates.io","fixed":["0.18.0"],"introduced":["0"],"last_affected":[],"package":"ethereum","purl":null,"source":"GHSA-3w94-vq2x-v5wr"},{"ecosystem":"crates.io","fixed":["0.18.0"],"introduced":["0"],"last_affected":[],"package":"ethereum","purl":"pkg:cargo/ethereum","source":"GHSA-3w94-vq2x-v5wr"}],"prev":{"headline":"kotaemon Vulnerable to Path Traversal via Link Upload","id":"CVE-2025-53358"},"products":["ethereum"],"published":"2025-07-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-03","vendors":["rust-ethereum"]},"summary":"The Rust ethereum library fails to check signature malleability for newer transaction types, potentially causing specification deviations in blockchain interactions.","url":"https://insights.sbomify.com/CVE-2025-53359/"}