# CVE-2025-53359: ethereum does not check transaction malleability for EIP-2930, EIP-1559 and EIP-7702 transactions

> The Rust ethereum library fails to check signature malleability for newer transaction types, potentially causing specification deviations in blockchain interactions.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2025
- **Updated:** 3 Jul 2025
- **Also known as:** GHSA-3w94-vq2x-v5wr

## What is CVE-2025-53359?

CVE-2025-53359 is a medium-severity vulnerability in rust-ethereum ethereum, published on 2 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ethereum is a common ethereum structs for Rust. Prior to ethereum crate v0.18.0, signature malleability (according to EIP-2) was only checked for "legacy" transactions, but not for EIP-2930, EIP-1559 and EIP-7702 transactions. This is a specification deviation. The signature malleability itself is not a security issue and not as high of a risk if the ethereum crate is used on a single-implementation blockchain. This issue has been patched in version v0.18.0. A workaround for this issue involves manually checking transaction malleability outside of the crate, however upgrading is recommended.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2025-53359?

2 open source packages ship an affected version, including ethereum.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethereum` | crates.io | All versions | 0.18.0 |
| `ethereum` | crates.io | All versions | 0.18.0 |

## How do I fix CVE-2025-53359?

Upgrade ethereum to 0.18.0 or later.

## Is CVE-2025-53359 being exploited?

There is no known exploitation of CVE-2025-53359 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53359 and fix it if it is affected.

What it is: CVE-2025-53359 is a medium-severity vulnerability in rust-ethereum ethereum, published on 2 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53359 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethereum (crates.io): affected all versions; fixed in 0.18.0
- ethereum (crates.io): affected all versions; fixed in 0.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53359/ (Markdown: https://insights.sbomify.com/CVE-2025-53359/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53359
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53359
- OSV: https://osv.dev/vulnerability/CVE-2025-53359

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53359/
Summaries are generated and may contain mistakes; the official description above is the record.
