CVE-2025-53364 Parse Server exposes the data schema via GraphQL API
Parse Server GraphQL API exposes schema metadata to unauthenticated users, potentially expanding the attack surface for further exploitation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-53364?
CVE-2025-53364 is a medium-severity vulnerability in parse-community parse-server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Starting in 5.3.0 and before 7.5.3 and 8.2.2, the Parse Server GraphQL API previously allowed public access to the GraphQL schema without requiring a session token or the master key. While schema introspection reveals only metadata and not actual data, this metadata can still expand the potential attack surface. This vulnerability is fixed in 7.5.3 and 8.2.2.
Weakness: CWE-497
Which versions are affected by CVE-2025-53364?
5 open source packages ship an affected version, including parse-server and parse.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | From 5.3.0 | 7.5.3 |
parse-server npm | From 5.3.0 | 7.5.3 |
parse-server npm | From 8.0.0 | 8.2.2 |
parse-server npm | From 8.0.0 | 8.2.2 |
parse Bitnami | From 5.3.0 | 8.2.2 |
How do I fix CVE-2025-53364?
Upgrade parse-server to a fixed version for your release line: 7.5.3 or 8.2.2.
Is CVE-2025-53364 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53364 exists.
Public exploit code: 1 Nuclei template.
Sources
Also known as BIT-parse-2025-53364, GHSA-48q3-prgv-gm4w.