{"answers":{"affected":"5 open source packages ship an affected version, including parse-server and parse.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53364 exists.","fix":"Upgrade parse-server to a fixed version for your release line: 7.5.3 or 8.2.2.","what":"CVE-2025-53364 is a medium-severity vulnerability in parse-community parse-server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53364 and fix it if it is affected.\n\nWhat it is: CVE-2025-53364 is a medium-severity vulnerability in parse-community parse-server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53364 exists.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected from 5.3.0; fixed in 7.5.3\n- parse-server (npm): affected from 5.3.0; fixed in 7.5.3\n- parse-server (npm): affected from 8.0.0; fixed in 8.2.2\n- parse-server (npm): affected from 8.0.0; fixed in 8.2.2\n- parse (Bitnami): affected from 5.3.0; fixed in 8.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53364/ (Markdown: https://insights.sbomify.com/CVE-2025-53364/index.md)","id":"CVE-2025-53364","markdown":"https://insights.sbomify.com/CVE-2025-53364/index.md","name":"CVE-2025-53364","record":{"aliases":["BIT-parse-2025-53364","GHSA-48q3-prgv-gm4w"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Parse Server backend","requires_auth":"none","summary":"Parse Server GraphQL API exposes schema metadata to unauthenticated users, potentially expanding the attack surface for further exploitation.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-497","name":"Exposure of Sensitive System Information to an Unauthorized Control Sphere"}],"description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Starting in 5.3.0 and before 7.5.3 and 8.2.2, the Parse Server GraphQL API previously allowed public access to the GraphQL schema without requiring a session token or the master key. While schema introspection reveals only metadata and not actual data, this metadata can still expand the potential attack surface. This vulnerability is fixed in 7.5.3 and 8.2.2.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2025/CVE-2025-53364.yaml","stars":null,"title":"Parse Server - GraphQL Schema Information Disclosure"}],"tier":"weaponised"},"has_fix":true,"headline":"Parse Server exposes the data schema via GraphQL API","id":"CVE-2025-53364","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":5,"n_references":3,"next":{"headline":"MCP Python SDK has Unhandled Exception in Streamable HTTP Transport ,Leading to Denial of Service","id":"CVE-2025-53365"},"packages":[{"ecosystem":"Bitnami","fixed":["8.2.2"],"introduced":["5.3.0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2025-53364"},{"ecosystem":"npm","fixed":["7.5.3"],"introduced":["5.3.0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-48q3-prgv-gm4w"},{"ecosystem":"npm","fixed":["7.5.3"],"introduced":["5.3.0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-48q3-prgv-gm4w"},{"ecosystem":"npm","fixed":["8.2.2"],"introduced":["8.0.0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-48q3-prgv-gm4w"},{"ecosystem":"npm","fixed":["8.2.2"],"introduced":["8.0.0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-48q3-prgv-gm4w"}],"prev":{"headline":"Dpanel has an arbitrary file read vulnerability","id":"CVE-2025-53363"},"products":["parse-server"],"published":"2025-07-10","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-10","vendors":["parse-community"]},"summary":"Parse Server GraphQL API exposes schema metadata to unauthenticated users, potentially expanding the attack surface for further exploitation.","url":"https://insights.sbomify.com/CVE-2025-53364/"}