# CVE-2025-53364: Parse Server exposes the data schema via GraphQL API

> Parse Server GraphQL API exposes schema metadata to unauthenticated users, potentially expanding the attack surface for further exploitation.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2025
- **Updated:** 10 Jul 2025
- **Also known as:** BIT-parse-2025-53364, GHSA-48q3-prgv-gm4w

## What is CVE-2025-53364?

CVE-2025-53364 is a medium-severity vulnerability in parse-community parse-server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Starting in 5.3.0 and before 7.5.3 and 8.2.2, the Parse Server GraphQL API previously allowed public access to the GraphQL schema without requiring a session token or the master key. While schema introspection reveals only metadata and not actual data, this metadata can still expand the potential attack surface. This vulnerability is fixed in 7.5.3 and 8.2.2.

Weakness: CWE-497 (Exposure of Sensitive System Information to an Unauthorized Control Sphere)

## Which versions are affected by CVE-2025-53364?

5 open source packages ship an affected version, including parse-server and parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | From 5.3.0 | 7.5.3 |
| `parse-server` | npm | From 5.3.0 | 7.5.3 |
| `parse-server` | npm | From 8.0.0 | 8.2.2 |
| `parse-server` | npm | From 8.0.0 | 8.2.2 |
| `parse` | Bitnami | From 5.3.0 | 8.2.2 |

## How do I fix CVE-2025-53364?

Upgrade parse-server to a fixed version for your release line: 7.5.3 or 8.2.2.

## Is CVE-2025-53364 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53364 exists.

Public exploit code:

- Parse Server - GraphQL Schema Information Disclosure (nuclei): http/cves/2025/CVE-2025-53364.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53364 and fix it if it is affected.

What it is: CVE-2025-53364 is a medium-severity vulnerability in parse-community parse-server, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53364 exists.

Affected packages and fixed versions:
- parse-server (npm): affected from 5.3.0; fixed in 7.5.3
- parse-server (npm): affected from 5.3.0; fixed in 7.5.3
- parse-server (npm): affected from 8.0.0; fixed in 8.2.2
- parse-server (npm): affected from 8.0.0; fixed in 8.2.2
- parse (Bitnami): affected from 5.3.0; fixed in 8.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53364/ (Markdown: https://insights.sbomify.com/CVE-2025-53364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53364
- OSV: https://osv.dev/vulnerability/CVE-2025-53364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53364/
Summaries are generated and may contain mistakes; the official description above is the record.
