# CVE-2025-53365: MCP Python SDK has Unhandled Exception in Streamable HTTP Transport ,Leading to Denial of Service

> A malicious client can crash the MCP Python SDK server by triggering an unhandled exception, requiring a restart to restore service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jul 2025
- **Updated:** 8 Jul 2025
- **Also known as:** GHSA-j975-95f5-7wqh, PYSEC-2026-1618, ROOT-APP-PYPI-CVE-2025-53365

## What is CVE-2025-53365?

CVE-2025-53365 is a high-severity denial of service vulnerability in modelcontextprotocol python-sdk, published on 4 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The MCP Python SDK, called `mcp` on PyPI, is a Python implementation of the Model Context Protocol (MCP). Prior to version 1.10.0, if a client deliberately triggers an exception after establishing a streamable HTTP session, this can lead to an uncaught ClosedResourceError on the server side, causing the server to crash and requiring a restart to restore service. Impact may vary depending on the deployment conditions, and presence of infrastructure-level resilience measures. Version 1.10.0 contains a patch for the issue.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-53365?

3 open source packages ship an affected version, including mcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp` | PyPI | All versions | 1.10.0 |
| `mcp` | PyPI | All versions | 1.10.0 |
| `mcp` | PyPI | All versions | 1.10.0 |

## How do I fix CVE-2025-53365?

Upgrade mcp to 1.10.0 or later.

## Is CVE-2025-53365 being exploited?

There is no known exploitation of CVE-2025-53365 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53365 and fix it if it is affected.

What it is: CVE-2025-53365 is a high-severity denial of service vulnerability in modelcontextprotocol python-sdk, published on 4 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53365 in the wild and no public exploit code.

Affected packages and fixed versions:
- mcp (PyPI): affected all versions; fixed in 1.10.0
- mcp (PyPI): affected all versions; fixed in 1.10.0
- mcp (PyPI): affected all versions; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53365/ (Markdown: https://insights.sbomify.com/CVE-2025-53365/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53365
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53365
- OSV: https://osv.dev/vulnerability/CVE-2025-53365

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53365/
Summaries are generated and may contain mistakes; the official description above is the record.
