{"answers":{"affected":"3 open source packages ship an affected version, including mcp.","exploited":"There is no known exploitation of CVE-2025-53366 in the wild and no public exploit code.","fix":"Upgrade mcp to 1.9.4 or later.","what":"CVE-2025-53366 is a high-severity denial of service vulnerability in modelcontextprotocol python-sdk, published on 4 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53366 and fix it if it is affected.\n\nWhat it is: CVE-2025-53366 is a high-severity denial of service vulnerability in modelcontextprotocol python-sdk, published on 4 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-53366 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mcp (PyPI): affected all versions; fixed in 1.9.4\n- mcp (PyPI): affected all versions; fixed in 1.9.4\n- mcp (PyPI): affected all versions; fixed in 1.9.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53366/ (Markdown: https://insights.sbomify.com/CVE-2025-53366/index.md)","id":"CVE-2025-53366","markdown":"https://insights.sbomify.com/CVE-2025-53366/index.md","name":"CVE-2025-53366","record":{"aliases":["GHSA-3qhf-m339-9g5v","PYSEC-2026-1616","ROOT-APP-PYPI-CVE-2025-53366"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"MCP Python SDK","requires_auth":"none","summary":"Attackers can cause service unavailability by sending malformed requests that trigger unhandled exceptions in the MCP Python SDK.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"The MCP Python SDK, called `mcp` on PyPI, is a Python implementation of the Model Context Protocol (MCP). Prior to version 1.9.4, a validation error in the MCP SDK can cause an unhandled exception when processing malformed requests, resulting in service unavailability (500 errors) until manually restarted. Impact may vary depending on the deployment conditions, and presence of infrastructure-level resilience measures. Version 1.9.4 contains a patch for the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MCP SDK Vulnerable to FastMCP Server Validation Error, Leading to Denial of Service","id":"CVE-2025-53366","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"DjVuLibre OOB-Write Vulnerability in MMRDecoder","id":"CVE-2025-53367"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.4"],"introduced":["0"],"last_affected":[],"package":"mcp","purl":null,"source":"GHSA-3qhf-m339-9g5v"},{"ecosystem":"PyPI","fixed":["1.9.4"],"introduced":["0"],"last_affected":[],"package":"mcp","purl":"pkg:pypi/mcp","source":"GHSA-3qhf-m339-9g5v"},{"ecosystem":"PyPI","fixed":["1.9.4"],"introduced":["0"],"last_affected":[],"package":"mcp","purl":"pkg:pypi/mcp","source":"PYSEC-2026-1616"}],"prev":{"headline":"MCP Python SDK has Unhandled Exception in Streamable HTTP Transport ,Leading to Denial of Service","id":"CVE-2025-53365"},"products":["python-sdk"],"published":"2025-07-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-08","vendors":["modelcontextprotocol"]},"summary":"Attackers can cause service unavailability by sending malformed requests that trigger unhandled exceptions in the MCP Python SDK.","url":"https://insights.sbomify.com/CVE-2025-53366/"}