{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53367 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2025-53367 is a high-severity memory corruption vulnerability in DjvuNet DjVuLibre, published on 3 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-53367 and fix it if it is affected.\n\nWhat it is: CVE-2025-53367 is a high-severity memory corruption vulnerability in DjvuNet DjVuLibre, published on 3 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53367 exists.\n\nAffected product: DjvuNet DjVuLibre. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53367/ (Markdown: https://insights.sbomify.com/CVE-2025-53367/index.md)","id":"CVE-2025-53367","markdown":"https://insights.sbomify.com/CVE-2025-53367/index.md","name":"CVE-2025-53367","record":{"aliases":["DEBIAN-CVE-2025-53367","DSA-5960-1","MGASA-2025-0209","OESA-2025-1756","SUSE-SU-2025:02695-1","SUSE-SU-2025:02703-1","UBUNTU-CVE-2025-53367","USN-7631-1","openSUSE-SU-2025:15319-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"DjVuLibre library","requires_auth":"none","summary":"An out-of-bounds write in DjVuLibre's MMRDecoder allows attackers to corrupt heap memory, potentially leading to code execution or crashes.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"DjVuLibre is a GPL implementation of DjVu, a web-centric format for distributing documents and images. Prior to version 3.5.29, the MMRDecoder::scanruns method is affected by an OOB-write vulnerability, because it does not check that the xr pointer stays within the bounds of the allocated buffer. This can lead to writes beyond the allocated memory, resulting in a heap corruption condition. An out-of-bounds read with pr is also possible for the same reason. This issue has been patched in version 3.5.29.","ecosystems":["SUSE:Linux Enterprise Module for Desktop Applications 15 SP6","SUSE:Linux Enterprise Module for Desktop Applications 15 SP7","SUSE:Linux Enterprise Module for Package Hub 15 SP6","SUSE:Linux Enterprise Module for Package Hub 15 SP7","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2025-07-18","github_poc":2,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-07-18T13:36:24Z","kind":"github_poc","ref":"https://github.com/kevinbackhouse/DjVuLibre-poc-CVE-2025-53367","stars":0,"title":null},{"date":"2025-11-17T17:03:46Z","kind":"github_poc","ref":"https://github.com/ThePhykon/CVE-2025-53367-POC","stars":0,"title":"A simple POC of the CVE-2025-53367, creating a .djvu-file which triggers an OOB-write in the heap"}],"tier":"weaponised"},"has_fix":true,"headline":"DjVuLibre OOB-Write Vulnerability in MMRDecoder","id":"CVE-2025-53367","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":7,"n_references":5,"next":{"headline":"Citizen is vulnerable to stored XSS attack in the legacy search bar","id":"CVE-2025-53368"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP6","fixed":["3.5.27-150200.11.17.1"],"introduced":["0"],"last_affected":[],"package":"djvulibre","purl":"pkg:rpm/suse/djvulibre\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP6","source":"SUSE-SU-2025:02703-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP7","fixed":["3.5.27-150200.11.17.1"],"introduced":["0"],"last_affected":[],"package":"djvulibre","purl":"pkg:rpm/suse/djvulibre\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP7","source":"SUSE-SU-2025:02703-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP6","fixed":["3.5.27-150200.11.17.1"],"introduced":["0"],"last_affected":[],"package":"djvulibre","purl":"pkg:rpm/suse/djvulibre\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP6","source":"SUSE-SU-2025:02703-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP7","fixed":["3.5.27-150200.11.17.1"],"introduced":["0"],"last_affected":[],"package":"djvulibre","purl":"pkg:rpm/suse/djvulibre\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP7","source":"SUSE-SU-2025:02703-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["3.5.25.3-5.25.1"],"introduced":["0"],"last_affected":[],"package":"djvulibre","purl":"pkg:rpm/suse/djvulibre\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2025:02695-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["3.5.27-150200.11.17.1"],"introduced":["0"],"last_affected":[],"package":"djvulibre","purl":"pkg:rpm/opensuse/djvulibre\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:02703-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.5.29-1.1"],"introduced":["0"],"last_affected":[],"package":"djvulibre","purl":"pkg:rpm/opensuse/djvulibre\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15319-1"}],"prev":{"headline":"MCP SDK Vulnerable to FastMCP Server Validation Error, Leading to Denial of Service","id":"CVE-2025-53366"},"products":["DjVuLibre"],"published":"2025-07-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["DjvuNet"]},"summary":"An out-of-bounds write in DjVuLibre's MMRDecoder allows attackers to corrupt heap memory, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2025-53367/"}