# CVE-2025-53367: DjVuLibre OOB-Write Vulnerability in MMRDecoder

> An out-of-bounds write in DjVuLibre's MMRDecoder allows attackers to corrupt heap memory, potentially leading to code execution or crashes.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-53367, DSA-5960-1, MGASA-2025-0209, OESA-2025-1756, SUSE-SU-2025:02695-1, SUSE-SU-2025:02703-1, UBUNTU-CVE-2025-53367, USN-7631-1, openSUSE-SU-2025:15319-1

## What is CVE-2025-53367?

CVE-2025-53367 is a high-severity memory corruption vulnerability in DjvuNet DjVuLibre, published on 3 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

DjVuLibre is a GPL implementation of DjVu, a web-centric format for distributing documents and images. Prior to version 3.5.29, the MMRDecoder::scanruns method is affected by an OOB-write vulnerability, because it does not check that the xr pointer stays within the bounds of the allocated buffer. This can lead to writes beyond the allocated memory, resulting in a heap corruption condition. An out-of-bounds read with pr is also possible for the same reason. This issue has been patched in version 3.5.29.

Weakness: CWE-787 (Out-of-bounds Write), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-53367?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `djvulibre` | SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | All versions | 3.5.27-150200.11.17.1 |
| `djvulibre` | SUSE:Linux Enterprise Module for Desktop Applications 15 SP7 | All versions | 3.5.27-150200.11.17.1 |
| `djvulibre` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 3.5.27-150200.11.17.1 |
| `djvulibre` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 3.5.27-150200.11.17.1 |
| `djvulibre` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 3.5.25.3-5.25.1 |
| `djvulibre` | openSUSE:Leap 15.6 | All versions | 3.5.27-150200.11.17.1 |
| `djvulibre` | openSUSE:Tumbleweed | All versions | 3.5.29-1.1 |

## How do I fix CVE-2025-53367?

Upgrade to a fixed version.

## Is CVE-2025-53367 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53367 exists.

Public exploit code:

- https://github.com/kevinbackhouse/DjVuLibre-poc-CVE-2025-53367 (github_poc): https://github.com/kevinbackhouse/DjVuLibre-poc-CVE-2025-53367
- A simple POC of the CVE-2025-53367, creating a .djvu-file which triggers an OOB-write in the heap (github_poc): https://github.com/ThePhykon/CVE-2025-53367-POC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53367 and fix it if it is affected.

What it is: CVE-2025-53367 is a high-severity memory corruption vulnerability in DjvuNet DjVuLibre, published on 3 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53367 exists.

Affected product: DjvuNet DjVuLibre. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53367/ (Markdown: https://insights.sbomify.com/CVE-2025-53367/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53367
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53367
- OSV: https://osv.dev/vulnerability/CVE-2025-53367

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53367/
Summaries are generated and may contain mistakes; the official description above is the record.
