# CVE-2025-53368: Citizen is vulnerable to stored XSS attack in the legacy search bar

> Stored XSS in Citizen MediaWiki skin allows attackers to inject scripts via page descriptions in the legacy search bar, affecting users who search for those pages.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2025
- **Updated:** 3 Jul 2025
- **Also known as:** GHSA-rq6g-6g94-jfr4

## What is CVE-2025-53368?

CVE-2025-53368 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 3 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. From versions 1.9.4 to before 3.4.0, page descriptions are inserted into raw HTML without proper sanitization by the Citizen skin when using the old search bar. Any user with page editing privileges can insert cross-site scripting (XSS) payloads into the DOM for other users who are searching for specific pages. This issue has been patched in version 3.4.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-53368?

2 open source packages ship an affected version, including starcitizentools/citizen-skin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starcitizentools/citizen-skin` | Packagist | From 1.9.4 | 3.4.0 |
| `starcitizentools/citizen-skin` | Packagist | From 1.9.4 | 3.4.0 |

Products: Starcitizen.tools Citizen.

## How do I fix CVE-2025-53368?

Upgrade starcitizentools/citizen-skin to 3.4.0 or later.

## Is CVE-2025-53368 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53368 exists.

## Other vulnerabilities in StarCitizenTools mediawiki-skins-Citizen

- [CVE-2025-53370](https://insights.sbomify.com/CVE-2025-53370/): Citizen stored XSS vulnerability through short descriptions (high 8.6)
- [CVE-2025-49575](https://insights.sbomify.com/CVE-2025-49575/): Citizen allows stored XSS in Command Palette tip messages (medium 6.5)
- [CVE-2025-49576](https://insights.sbomify.com/CVE-2025-49576/): Citizen allows stored XSS in search no result messages (medium 6.5)
- [CVE-2025-49577](https://insights.sbomify.com/CVE-2025-49577/): Citizen allows stored XSS in preference menu headings (medium 6.5)
- [CVE-2025-49578](https://insights.sbomify.com/CVE-2025-49578/): Citizen allows stored XSS in user registration date message (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53368 and fix it if it is affected.

What it is: CVE-2025-53368 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 3 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53368 exists.

Affected packages and fixed versions:
- starcitizentools/citizen-skin (Packagist): affected from 1.9.4; fixed in 3.4.0
- starcitizentools/citizen-skin (Packagist): affected from 1.9.4; fixed in 3.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53368/ (Markdown: https://insights.sbomify.com/CVE-2025-53368/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53368
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53368
- OSV: https://osv.dev/vulnerability/CVE-2025-53368

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53368/
Summaries are generated and may contain mistakes; the official description above is the record.
