{"answers":{"affected":"2 open source packages ship an affected version, including starcitizentools/short-description.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53369 exists.","fix":"Upgrade starcitizentools/short-description to 4.0.1 or later.","what":"CVE-2025-53369 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-extensions-ShortDescription, published on 3 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53369 and fix it if it is affected.\n\nWhat it is: CVE-2025-53369 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-extensions-ShortDescription, published on 3 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53369 exists.\n\nAffected packages and fixed versions:\n- starcitizentools/short-description (Packagist): affected from 4.0.0; fixed in 4.0.1\n- starcitizentools/short-description (Packagist): affected from 4.0.0; fixed in 4.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53369/ (Markdown: https://insights.sbomify.com/CVE-2025-53369/index.md)","id":"CVE-2025-53369","markdown":"https://insights.sbomify.com/CVE-2025-53369/index.md","name":"CVE-2025-53369","record":{"aliases":["GHSA-p85q-mww9-gwqf"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki extension","requires_auth":"none","summary":"An attacker can inject arbitrary HTML into the DOM via unsanitized short descriptions, potentially executing malicious scripts in victim browsers.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Short Description is a MediaWiki extension that provides local short description support. In version 4.0.0, short descriptions are not properly sanitized before being inserted as HTML using mw.util.addSubtitle, allowing any user to insert arbitrary HTML into the DOM by editing a page. This issue has been patched in version 4.0.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Citizen Short Description stored XSS vulnerability through wikitext","id":"CVE-2025-53369","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Citizen stored XSS vulnerability through short descriptions","id":"CVE-2025-53370"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.1"],"introduced":["4.0.0"],"last_affected":[],"package":"starcitizentools/short-description","purl":null,"source":"GHSA-p85q-mww9-gwqf"},{"ecosystem":"Packagist","fixed":["4.0.1"],"introduced":["4.0.0"],"last_affected":[],"package":"starcitizentools/short-description","purl":"pkg:composer/starcitizentools/short-description","source":"GHSA-p85q-mww9-gwqf"}],"prev":{"headline":"Citizen is vulnerable to stored XSS attack in the legacy search bar","id":"CVE-2025-53368"},"products":["mediawiki-extensions-ShortDescription"],"published":"2025-07-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-03","vendors":["StarCitizenTools"]},"summary":"An attacker can inject arbitrary HTML into the DOM via unsanitized short descriptions, potentially executing malicious scripts in victim browsers.","url":"https://insights.sbomify.com/CVE-2025-53369/"}