# CVE-2025-53369: Citizen Short Description stored XSS vulnerability through wikitext

> An attacker can inject arbitrary HTML into the DOM via unsanitized short descriptions, potentially executing malicious scripts in victim browsers.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2025
- **Updated:** 3 Jul 2025
- **Also known as:** GHSA-p85q-mww9-gwqf

## What is CVE-2025-53369?

CVE-2025-53369 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-extensions-ShortDescription, published on 3 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Short Description is a MediaWiki extension that provides local short description support. In version 4.0.0, short descriptions are not properly sanitized before being inserted as HTML using mw.util.addSubtitle, allowing any user to insert arbitrary HTML into the DOM by editing a page. This issue has been patched in version 4.0.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-53369?

2 open source packages ship an affected version, including starcitizentools/short-description.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starcitizentools/short-description` | Packagist | From 4.0.0 | 4.0.1 |
| `starcitizentools/short-description` | Packagist | From 4.0.0 | 4.0.1 |

## How do I fix CVE-2025-53369?

Upgrade starcitizentools/short-description to 4.0.1 or later.

## Is CVE-2025-53369 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53369 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53369 and fix it if it is affected.

What it is: CVE-2025-53369 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-extensions-ShortDescription, published on 3 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53369 exists.

Affected packages and fixed versions:
- starcitizentools/short-description (Packagist): affected from 4.0.0; fixed in 4.0.1
- starcitizentools/short-description (Packagist): affected from 4.0.0; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53369/ (Markdown: https://insights.sbomify.com/CVE-2025-53369/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53369
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53369
- OSV: https://osv.dev/vulnerability/CVE-2025-53369

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53369/
Summaries are generated and may contain mistakes; the official description above is the record.
