CVE-2025-53370 Citizen stored XSS vulnerability through short descriptions

High 8.6 Published Updated

An attacker can inject arbitrary HTML into the DOM via short descriptions in the Citizen MediaWiki skin, potentially executing malicious scripts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-53370?

CVE-2025-53370 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-skins-Citizen, published on 3 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. From versions 1.9.4 to before 3.4.0, short descriptions set via the ShortDescription extension are inserted as raw HTML by the Citizen skin, allowing any user to insert arbitrary HTML into the DOM by editing a page. This issue has been patched in version 3.4.0.

Weakness: CWE-79

Which versions are affected by CVE-2025-53370?

2 open source packages ship an affected version, including starcitizentools/citizen-skin. It affects 1 product.

PackageAffectedFixed in
starcitizentools/citizen-skin PackagistFrom 1.9.43.4.0
starcitizentools/citizen-skin PackagistFrom 1.9.43.4.0

Products include Starcitizen.tools Citizen.

How do I fix CVE-2025-53370?

Upgrade starcitizentools/citizen-skin to 3.4.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-53370 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53370 exists.

Sources

Also known as GHSA-prmv-7r8c-794g.

Is CVE-2025-53370 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free