# CVE-2025-53372: node-code-sandbox-mcp has a Sandbox Escape via Command Injection

> Attackers can execute arbitrary system commands on the host by injecting input into the MCP server, bypassing Docker sandbox protections.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2025
- **Updated:** 8 Jul 2025
- **Also known as:** GHSA-5w57-2ccq-8w95

## What is CVE-2025-53372?

CVE-2025-53372 is a high-severity command injection vulnerability in alfonsograziano node-code-sandbox-mcp, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

node-code-sandbox-mcp is a Node.js–based Model Context Protocol server that spins up disposable Docker containers to execute arbitrary JavaScript. Prior to 1.3.0, a command injection vulnerability exists in the node-code-sandbox-mcp MCP Server. The vulnerability is caused by the unsanitized use of input parameters within a call to child_process.execSync, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges on the host machine, bypassing the sandbox protection of running code inside docker. This vulnerability is fixed in 1.3.0.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-53372?

2 open source packages ship an affected version, including node-code-sandbox-mcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-code-sandbox-mcp` | npm | All versions | 1.3.0 |
| `node-code-sandbox-mcp` | npm | All versions | 1.3.0 |

## How do I fix CVE-2025-53372?

Upgrade node-code-sandbox-mcp to 1.3.0 or later.

## Is CVE-2025-53372 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53372 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53372 and fix it if it is affected.

What it is: CVE-2025-53372 is a high-severity command injection vulnerability in alfonsograziano node-code-sandbox-mcp, published on 8 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53372 exists.

Affected packages and fixed versions:
- node-code-sandbox-mcp (npm): affected all versions; fixed in 1.3.0
- node-code-sandbox-mcp (npm): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53372/ (Markdown: https://insights.sbomify.com/CVE-2025-53372/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53372
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53372
- OSV: https://osv.dev/vulnerability/CVE-2025-53372

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53372/
Summaries are generated and may contain mistakes; the official description above is the record.
