CVE-2025-53470 Apache Mynewt NimBLE: Out-of-Bounds Write Vulnerability in NimBLE HCI H4 driver

Low 3.1 Published Updated

A crafted HCI event in the NimBLE H4 driver causes an out-of-bounds read, potentially leading to crashes or information disclosure.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-53470?

CVE-2025-53470 is a low-severity memory corruption vulnerability in Apache Mynewt NimBLE, published on 10 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Out-of-bounds Read vulnerability in Apache NimBLE HCI H4 driver. Specially crafted HCI event could lead to invalid memory read in H4 driver.

This issue affects Apache NimBLE: through 1.8. 

This issue requires a broken or bogus Bluetooth controller and thus severity is considered low.

Users are recommended to upgrade to version 1.9, which fixes the issue.

Weakness: CWE-125

Which versions are affected by CVE-2025-53470?

It affects 1 product.

Products include Apache Nimble.

How do I fix CVE-2025-53470?

No fix has been published for CVE-2025-53470 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-53470 being exploited?

There is no known exploitation of CVE-2025-53470 in the wild and no public exploit code.

Sources

Also known as GHSA-p54q-9gfq-fvp4.

Is CVE-2025-53470 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free