{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-53470 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-53470 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-53470 is a low-severity memory corruption vulnerability in Apache Mynewt NimBLE, published on 10 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53470 and fix it if it is affected.\n\nWhat it is: CVE-2025-53470 is a low-severity memory corruption vulnerability in Apache Mynewt NimBLE, published on 10 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-53470 in the wild and no public exploit code.\n\nAffected product: Apache Mynewt NimBLE. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53470/ (Markdown: https://insights.sbomify.com/CVE-2025-53470/index.md)","id":"CVE-2025-53470","markdown":"https://insights.sbomify.com/CVE-2025-53470/index.md","name":"CVE-2025-53470","record":{"aliases":["GHSA-p54q-9gfq-fvp4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","other"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Bluetooth stack library","requires_auth":"none","summary":"A crafted HCI event in the NimBLE H4 driver causes an out-of-bounds read, potentially leading to crashes or information disclosure.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"nimble","vendor":"apache"}],"cvss":{"score":3.1,"severity":"low","source":"cisa-adp","vector":"CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Out-of-bounds Read vulnerability in Apache  NimBLE HCI H4 driver. Specially crafted HCI event could lead to invalid memory read in H4 driver.\n\nThis issue affects Apache NimBLE: through 1.8. \n\nThis issue requires a broken or bogus Bluetooth controller and thus severity is considered low.\n\nUsers are recommended to upgrade to version 1.9, which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache Mynewt NimBLE: Out-of-Bounds Write Vulnerability in NimBLE HCI H4 driver","id":"CVE-2025-53470","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Emerson ValveLink Products Improper Input Validation","id":"CVE-2025-53471"},"packages":[],"prev":{"headline":"WordPress BMI Adult \u0026 Kid Calculator Plugin \u003c= 1.2.2 - Cross Site Scripting (XSS) Vulnerability","id":"CVE-2025-53469"},"products":["Apache Mynewt NimBLE"],"published":"2026-01-10","related":[{"cvss_score":8.8,"headline":"Apache NimBLE: Incorrect data validation in BASS add/modify source operation","id":"CVE-2026-45813","kev_date_added":null,"published":"2026-07-24"},{"cvss_score":8.1,"headline":"Apache Mynewt NimBLE: Incorrect handling of SMP Security Request could lead to undesirable pairing","id":"CVE-2025-62235","kev_date_added":null,"published":"2026-01-10"},{"cvss_score":7.5,"headline":"Apache NimBLE: Buffer overflow in socket HCI transport","id":"CVE-2026-45811","kev_date_added":null,"published":"2026-07-24"},{"cvss_score":7.5,"headline":"Apache NimBLE: Remote reachable assertion in ATT Read Multiple Variable Response handler","id":"CVE-2026-45815","kev_date_added":null,"published":"2026-07-24"},{"cvss_score":7.5,"headline":"Apache NimBLE: NULL pointer dereference vulnerability in SMP LTK request","id":"CVE-2026-45816","kev_date_added":null,"published":"2026-07-24"},{"cvss_score":7.5,"headline":"Apache Mynewt NimBLE: Invalid error handling in pause encryption procedure in NimBLE controller","id":"CVE-2025-52435","kev_date_added":null,"published":"2026-01-10"},{"cvss_score":7.5,"headline":"Apache Mynewt NimBLE: NULL Pointer Dereference in NimBLE host HCI layer","id":"CVE-2025-53477","kev_date_added":null,"published":"2026-01-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-12","vendors":["Apache Software Foundation"]},"summary":"A crafted HCI event in the NimBLE H4 driver causes an out-of-bounds read, potentially leading to crashes or information disclosure.","url":"https://insights.sbomify.com/CVE-2025-53470/"}