# CVE-2025-53470: Apache Mynewt NimBLE: Out-of-Bounds Write Vulnerability in NimBLE HCI H4 driver

> A crafted HCI event in the NimBLE H4 driver causes an out-of-bounds read, potentially leading to crashes or information disclosure.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-p54q-9gfq-fvp4

## What is CVE-2025-53470?

CVE-2025-53470 is a low-severity memory corruption vulnerability in Apache Mynewt NimBLE, published on 10 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Out-of-bounds Read vulnerability in Apache  NimBLE HCI H4 driver. Specially crafted HCI event could lead to invalid memory read in H4 driver.

This issue affects Apache NimBLE: through 1.8. 

This issue requires a broken or bogus Bluetooth controller and thus severity is considered low.

Users are recommended to upgrade to version 1.9, which fixes the issue.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-53470?

It affects 1 product.


Products: Apache Nimble.

## How do I fix CVE-2025-53470?

No fix has been published for CVE-2025-53470 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-53470 being exploited?

There is no known exploitation of CVE-2025-53470 in the wild and no public exploit code.

## Other vulnerabilities in Apache Mynewt NimBLE

- [CVE-2026-45813](https://insights.sbomify.com/CVE-2026-45813/): Apache NimBLE: Incorrect data validation in BASS add/modify source operation (high 8.8)
- [CVE-2025-62235](https://insights.sbomify.com/CVE-2025-62235/): Apache Mynewt NimBLE: Incorrect handling of SMP Security Request could lead to undesirable pairing (high 8.1)
- [CVE-2026-45811](https://insights.sbomify.com/CVE-2026-45811/): Apache NimBLE: Buffer overflow in socket HCI transport (high 7.5)
- [CVE-2026-45815](https://insights.sbomify.com/CVE-2026-45815/): Apache NimBLE: Remote reachable assertion in ATT Read Multiple Variable Response handler (high 7.5)
- [CVE-2026-45816](https://insights.sbomify.com/CVE-2026-45816/): Apache NimBLE: NULL pointer dereference vulnerability in SMP LTK request (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53470 and fix it if it is affected.

What it is: CVE-2025-53470 is a low-severity memory corruption vulnerability in Apache Mynewt NimBLE, published on 10 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53470 in the wild and no public exploit code.

Affected product: Apache Mynewt NimBLE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53470/ (Markdown: https://insights.sbomify.com/CVE-2025-53470/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53470
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53470
- OSV: https://osv.dev/vulnerability/CVE-2025-53470

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53470/
Summaries are generated and may contain mistakes; the official description above is the record.
