CVE-2025-53506 Apache Tomcat: DoS via excessive h2 streams at connection start
An attacker can cause a denial of service in Apache Tomcat by sending excessive HTTP/2 streams before acknowledging initial settings.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-53506?
CVE-2025-53506 is a high-severity denial of service vulnerability in Apache Tomcat, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Uncontrolled Resource Consumption vulnerability in Apache Tomcat if an HTTP/2 client did not acknowledge the initial settings frame that reduces the maximum permitted concurrent streams.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.
Weakness: CWE-400
Which versions are affected by CVE-2025-53506?
17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.43 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.43 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.9 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.9 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
11 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.107 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0.M1 | 9.0.107 |
tomcat Bitnami | All versions | 9.0.107, 10.1.43, 11.0.9 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.43 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.43 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.9 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.9 |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0.M1 | 9.0.107 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0.M1 | 9.0.107 |
Products include Apache Tomcat.
How do I fix CVE-2025-53506?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.43, 11.0.9 or 9.0.107.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-53506 being exploited?
There is no known exploitation of CVE-2025-53506 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-53506, DEBIAN-CVE-2025-53506, GHSA-25xr-qj8w-c4vf, MINI-4h6v-p7v8-p24c, MINI-5x2j-9vh8-h88j, MINI-993j-xmpc-46fq and 5 more.