{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5352 exists.","fix":"No fix has been published for CVE-2025-5352 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-5352 is a high-severity cross-site scripting vulnerability in Lunary Lunary, published on 23 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-5352 and fix it if it is affected.\n\nWhat it is: CVE-2025-5352 is a high-severity cross-site scripting vulnerability in Lunary Lunary, published on 23 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5352 exists.\n\nAffected product: Lunary Lunary. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5352/ (Markdown: https://insights.sbomify.com/CVE-2025-5352/index.md)","id":"CVE-2025-5352","markdown":"https://insights.sbomify.com/CVE-2025-5352/index.md","name":"CVE-2025-5352","record":{"aliases":["GHSA-6cxf-c9x7-g2q5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Lunary AI analytics","requires_auth":"none","summary":"Stored XSS in Lunary AI allows arbitrary JavaScript execution via environment variables, leading to account takeover and data exfiltration for all users.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"lunary","vendor":"lunary"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A critical stored Cross-Site Scripting (XSS) vulnerability exists in the Analytics component of lunary-ai/lunary versions up to 1.9.23, where the NEXT_PUBLIC_CUSTOM_SCRIPT environment variable is directly injected into the DOM using dangerouslySetInnerHTML without any sanitization or validation. This allows arbitrary JavaScript execution in all users' browsers if an attacker can control the environment variable during deployment or through server compromise. The vulnerability can lead to complete account takeover, data exfiltration, malware distribution, and persistent attacks affecting all users until the environment variable is cleaned. The issue is fixed in version 1.9.25.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2025-12-05","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-12-05T19:56:25Z","kind":"github_poc","ref":"https://github.com/sahiloj/CVE-2025-5352","stars":0,"title":"A stored XSS vulnerability exists in the Analytics component of lunary-ai/lunary where NEXT_PUBLIC_CUSTOM_SCRIPT is injected into the DOM using dangerouslySetInnerHTML without sanitization. An attacker controlling this variable during deployment or via server compromise can run arbitrary JavaScript in all users’ browsers."}],"tier":"weaponised"},"has_fix":null,"headline":"Environment Variable XSS in Analytics Component in lunary-ai/lunary","id":"CVE-2025-5352","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"lunary:lunary","products":["lunary:lunary"],"type":"xss","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Hardcoded credentials in Workspace Control","id":"CVE-2025-5353"},"packages":[],"prev":{"headline":"Libssh: double free vulnerability in libssh key export functions","id":"CVE-2025-5351"},"products":["lunary-ai/lunary"],"published":"2025-08-23","related":[{"cvss_score":9.8,"headline":"Improper Access Control in lunary-ai/lunary","id":"CVE-2024-8999","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.8,"headline":"Improper Authorization in lunary-ai/lunary","id":"CVE-2024-9095","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.8,"headline":"SQL Injection in lunary-ai/lunary","id":"CVE-2024-7456","kev_date_added":null,"published":"2024-11-01"},{"cvss_score":9.8,"headline":"Incorrect Authorization in lunary-ai/lunary","id":"CVE-2024-4146","kev_date_added":null,"published":"2024-06-08"},{"cvss_score":9.6,"headline":"Account Hijacking via Password Reset Token Leak in lunary-ai/lunary","id":"CVE-2024-5386","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.6,"headline":"Incorrect Authorization in lunary-ai/lunary","id":"CVE-2024-3379","kev_date_added":null,"published":"2024-11-14"},{"cvss_score":9.4,"headline":"IDOR Vulnerability in lunary-ai/lunary","id":"CVE-2024-5128","kev_date_added":null,"published":"2024-06-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-25","vendors":["lunary-ai"]},"summary":"Stored XSS in Lunary AI allows arbitrary JavaScript execution via environment variables, leading to account takeover and data exfiltration for all users.","url":"https://insights.sbomify.com/CVE-2025-5352/"}