# CVE-2025-5352: Environment Variable XSS in Analytics Component in lunary-ai/lunary

> Stored XSS in Lunary AI allows arbitrary JavaScript execution via environment variables, leading to account takeover and data exfiltration for all users.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Aug 2025
- **Updated:** 25 Aug 2025
- **Also known as:** GHSA-6cxf-c9x7-g2q5

## What is CVE-2025-5352?

CVE-2025-5352 is a high-severity cross-site scripting vulnerability in Lunary Lunary, published on 23 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A critical stored Cross-Site Scripting (XSS) vulnerability exists in the Analytics component of lunary-ai/lunary versions up to 1.9.23, where the NEXT_PUBLIC_CUSTOM_SCRIPT environment variable is directly injected into the DOM using dangerouslySetInnerHTML without any sanitization or validation. This allows arbitrary JavaScript execution in all users' browsers if an attacker can control the environment variable during deployment or through server compromise. The vulnerability can lead to complete account takeover, data exfiltration, malware distribution, and persistent attacks affecting all users until the environment variable is cleaned. The issue is fixed in version 1.9.25.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-5352?

It affects 1 product.


Products: Lunary Lunary.

## How do I fix CVE-2025-5352?

No fix has been published for CVE-2025-5352 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-5352 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5352 exists.

Public exploit code:

- A stored XSS vulnerability exists in the Analytics component of lunary-ai/lunary where NEXT_PUBLIC_CUSTOM_SCRIPT is injected into the DOM using dangerouslySetInnerHTML without sanitization. An attacker controlling this variable during deployment or via server compromise can run arbitrary JavaScript in all users’ browsers. (github_poc): https://github.com/sahiloj/CVE-2025-5352

## Other vulnerabilities in Lunary Lunary

- [CVE-2024-8999](https://insights.sbomify.com/CVE-2024-8999/): Improper Access Control in lunary-ai/lunary (critical 9.8)
- [CVE-2024-9095](https://insights.sbomify.com/CVE-2024-9095/): Improper Authorization in lunary-ai/lunary (critical 9.8)
- [CVE-2024-7456](https://insights.sbomify.com/CVE-2024-7456/): SQL Injection in lunary-ai/lunary (critical 9.8)
- [CVE-2024-4146](https://insights.sbomify.com/CVE-2024-4146/): Incorrect Authorization in lunary-ai/lunary (critical 9.8)
- [CVE-2024-5386](https://insights.sbomify.com/CVE-2024-5386/): Account Hijacking via Password Reset Token Leak in lunary-ai/lunary (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5352 and fix it if it is affected.

What it is: CVE-2025-5352 is a high-severity cross-site scripting vulnerability in Lunary Lunary, published on 23 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5352 exists.

Affected product: Lunary Lunary. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5352/ (Markdown: https://insights.sbomify.com/CVE-2025-5352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5352
- OSV: https://osv.dev/vulnerability/CVE-2025-5352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5352/
Summaries are generated and may contain mistakes; the official description above is the record.
