{"answers":{"affected":"3 open source packages ship an affected version, including cadwyn.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53528 exists.","fix":"Upgrade cadwyn to 5.4.3 or later.","what":"CVE-2025-53528 is a high-severity cross-site scripting vulnerability in zmievsa cadwyn, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-53528 and fix it if it is affected.\n\nWhat it is: CVE-2025-53528 is a high-severity cross-site scripting vulnerability in zmievsa cadwyn, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53528 exists.\n\nAffected packages and fixed versions:\n- cadwyn (PyPI): affected all versions; fixed in 5.4.3\n- cadwyn (PyPI): affected all versions; fixed in 5.4.3\n- cadwyn (PyPI): affected all versions; fixed in 5.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53528/ (Markdown: https://insights.sbomify.com/CVE-2025-53528/index.md)","id":"CVE-2025-53528","markdown":"https://insights.sbomify.com/CVE-2025-53528/index.md","name":"CVE-2025-53528","record":{"aliases":["GHSA-2gxp-6r36-m97r","PYSEC-2025-71"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python API versioning library","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript in a user's session via a reflected XSS vulnerability in the Cadwyn library's docs endpoint.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cadwyn creates production-ready community-driven modern Stripe-like API versioning in FastAPI. In versions before 5.4.3, the version parameter of the \"/docs\" endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack. This XSS would notably allow an attacker to execute JavaScript code on a user's session for any application based on Cadwyn via a one-click attack. The vulnerability has been fixed in version 5.4.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cadwyn is vulnerable to an XSS attack through its docs page","id":"CVE-2025-53528","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"WeGIA allows SQL Injection in html/funcionario/profile_funcionario.php (id_funcionario parameter)","id":"CVE-2025-53529"},"packages":[{"ecosystem":"PyPI","fixed":["5.4.3"],"introduced":["0"],"last_affected":[],"package":"cadwyn","purl":null,"source":"GHSA-2gxp-6r36-m97r"},{"ecosystem":"PyPI","fixed":["5.4.3"],"introduced":["0"],"last_affected":[],"package":"cadwyn","purl":"pkg:pypi/cadwyn","source":"GHSA-2gxp-6r36-m97r"},{"ecosystem":"PyPI","fixed":["5.4.3"],"introduced":["0"],"last_affected":[],"package":"cadwyn","purl":"pkg:pypi/cadwyn","source":"PYSEC-2025-71"}],"prev":{"headline":"WeGIA allows Time-Based Blind SQL Injection in the relatorio_geracao.php endpoint","id":"CVE-2025-53527"},"products":["cadwyn"],"published":"2025-07-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-23","vendors":["zmievsa"]},"summary":"An attacker can execute arbitrary JavaScript in a user's session via a reflected XSS vulnerability in the Cadwyn library's docs endpoint.","url":"https://insights.sbomify.com/CVE-2025-53528/"}