# CVE-2025-53528: Cadwyn is vulnerable to an XSS attack through its docs page

> An attacker can execute arbitrary JavaScript in a user's session via a reflected XSS vulnerability in the Cadwyn library's docs endpoint.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jul 2025
- **Updated:** 23 Jul 2025
- **Also known as:** GHSA-2gxp-6r36-m97r, PYSEC-2025-71

## What is CVE-2025-53528?

CVE-2025-53528 is a high-severity cross-site scripting vulnerability in zmievsa cadwyn, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cadwyn creates production-ready community-driven modern Stripe-like API versioning in FastAPI. In versions before 5.4.3, the version parameter of the "/docs" endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack. This XSS would notably allow an attacker to execute JavaScript code on a user's session for any application based on Cadwyn via a one-click attack. The vulnerability has been fixed in version 5.4.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-53528?

3 open source packages ship an affected version, including cadwyn.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cadwyn` | PyPI | All versions | 5.4.3 |
| `cadwyn` | PyPI | All versions | 5.4.3 |
| `cadwyn` | PyPI | All versions | 5.4.3 |

## How do I fix CVE-2025-53528?

Upgrade cadwyn to 5.4.3 or later.

## Is CVE-2025-53528 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53528 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53528 and fix it if it is affected.

What it is: CVE-2025-53528 is a high-severity cross-site scripting vulnerability in zmievsa cadwyn, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53528 exists.

Affected packages and fixed versions:
- cadwyn (PyPI): affected all versions; fixed in 5.4.3
- cadwyn (PyPI): affected all versions; fixed in 5.4.3
- cadwyn (PyPI): affected all versions; fixed in 5.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53528/ (Markdown: https://insights.sbomify.com/CVE-2025-53528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53528
- OSV: https://osv.dev/vulnerability/CVE-2025-53528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53528/
Summaries are generated and may contain mistakes; the official description above is the record.
