# CVE-2025-53534: RatPanel can perform remote command execution without authorization

> Attackers can bypass authentication to execute remote commands and take over hosts if they know the backend login path.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2025
- **Updated:** 6 Aug 2025
- **Also known as:** GHSA-fm3m-jrgm-5ppg, GO-2025-3844

## What is CVE-2025-53534?

CVE-2025-53534 is a high-severity authentication bypass vulnerability in tnb-labs panel, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RatPanel is a server operation and maintenance management panel. In versions 2.3.19 through 2.5.5, when an attacker obtains the backend login path of RatPanel (including but not limited to weak default paths, brute-force cracking, etc.), they can execute system commands or take over hosts managed by the panel without logging in. In addition to this remote code execution (RCE) vulnerability, the flawed code also leads to unauthorized access. RatPanel uses the CleanPath middleware provided by github.com/go-chi/chi package to clean URLs, but but the middleware does not process r.URL.Path, which can cause the paths to be misinterpreted. This is fixed in version 2.5.6.

Weakness: CWE-305 (Authentication Bypass by Primary Weakness)

## Which versions are affected by CVE-2025-53534?

7 open source packages ship an affected version, including github.com/tnb-labs/panel, github.com/TheTNB/panel and github.com/TheTNB/panel/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/tnb-labs/panel` | Go | All versions | 0.0.0-20250707071915-4985eb2e1f38 |
| `github.com/TheTNB/panel` | Go | From 0.0.0-20241111062800-91ecd04c2700 | None |
| `github.com/TheTNB/panel/v2` | Go | All versions | None |
| `github.com/tnborg/panel` | Go | From 0.0.0-20241111062800-91ecd04c2700 | 0.0.0-20250707071915-4985eb2e1f38 |
| `github.com/tnborg/panel` | Go | From 0.0.0-20241111062800-91ecd04c2700 | 0.0.0-20250707071915-4985eb2e1f38 |
| `github.com/tnborg/panel` | Go | From 2.3.19 | 2.5.6 |
| `github.com/tnborg/panel` | Go | From 2.3.19 | 2.5.6 |

## How do I fix CVE-2025-53534?

Upgrade github.com/tnb-labs/panel to 0.0.0-20250707071915-4985eb2e1f38 or later.

## Is CVE-2025-53534 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53534 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53534 and fix it if it is affected.

What it is: CVE-2025-53534 is a high-severity authentication bypass vulnerability in tnb-labs panel, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53534 exists.

Affected packages and fixed versions:
- github.com/tnb-labs/panel (Go): affected all versions; fixed in 0.0.0-20250707071915-4985eb2e1f38
- github.com/TheTNB/panel (Go): affected from 0.0.0-20241111062800-91ecd04c2700; no fix listed
- github.com/TheTNB/panel/v2 (Go): affected all versions; no fix listed
- github.com/tnborg/panel (Go): affected from 0.0.0-20241111062800-91ecd04c2700; fixed in 0.0.0-20250707071915-4985eb2e1f38
- github.com/tnborg/panel (Go): affected from 0.0.0-20241111062800-91ecd04c2700; fixed in 0.0.0-20250707071915-4985eb2e1f38
- github.com/tnborg/panel (Go): affected from 2.3.19; fixed in 2.5.6
- github.com/tnborg/panel (Go): affected from 2.3.19; fixed in 2.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53534/ (Markdown: https://insights.sbomify.com/CVE-2025-53534/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53534
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53534
- OSV: https://osv.dev/vulnerability/CVE-2025-53534

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53534/
Summaries are generated and may contain mistakes; the official description above is the record.
