# CVE-2025-53535: Better Auth has an Open Redirect Vulnerability in originCheck Middleware Affecting Multiple Routes

> An open redirect in Better Auth's originCheck middleware allows attackers to redirect users to malicious sites via specific authentication routes.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2025
- **Updated:** 7 Jul 2025
- **Also known as:** GHSA-36rg-gfq2-3h56

## What is CVE-2025-53535?

CVE-2025-53535 is a low-severity vulnerability in better-auth, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Better Auth is an authentication and authorization library for TypeScript. An open redirect has been found in the originCheck middleware function, which affects the following routes: /verify-email, /reset-password/:token, /delete-user/callback, /magic-link/verify, /oauth-proxy-callback. This vulnerability is fixed in 1.2.10.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-53535?

2 open source packages ship an affected version, including better-auth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.2.10 |
| `better-auth` | npm | All versions | 1.2.10 |

## How do I fix CVE-2025-53535?

Upgrade better-auth to 1.2.10 or later.

## Is CVE-2025-53535 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53535 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53535 and fix it if it is affected.

What it is: CVE-2025-53535 is a low-severity vulnerability in better-auth, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53535 exists.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.2.10
- better-auth (npm): affected all versions; fixed in 1.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53535/ (Markdown: https://insights.sbomify.com/CVE-2025-53535/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53535
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53535
- OSV: https://osv.dev/vulnerability/CVE-2025-53535

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53535/
Summaries are generated and may contain mistakes; the official description above is the record.
