CVE-2025-53537 LibHTP's memory leak with lzma can lead to resource starvation

High 7.5 Published Updated

A memory leak in LibHTP's LZMA handling allows attackers to exhaust system memory, causing denial of service and loss of visibility.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-53537?

CVE-2025-53537 is a high-severity denial of service vulnerability in OISF libhtp, published on 23 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

LibHTP is a security-aware parser for the HTTP protocol and its related bits and pieces. In versions 0.5.50 and below, there is a traffic-induced memory leak that can starve the process of memory, leading to loss of visibility. To workaround this issue, set `suricata.yaml app-layer.protocols.http.libhtp.default-config.lzma-enabled` to false. This issue is fixed in version 0.5.51.

Weakness: CWE-401

Which versions are affected by CVE-2025-53537?

It affects 1 product.

Products include Oisf Libhtp.

How do I fix CVE-2025-53537?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-53537 being exploited?

There is no known exploitation of CVE-2025-53537 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2025-53537, GHSA-v3qq-h8mh-vph7, UBUNTU-CVE-2025-53537.

Is CVE-2025-53537 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free