{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-53542 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-53542 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-53542 is a high-severity command injection vulnerability in kubernetes-sigs headlamp, published on 10 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-53542 and fix it if it is affected.\n\nWhat it is: CVE-2025-53542 is a high-severity command injection vulnerability in kubernetes-sigs headlamp, published on 10 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-53542 in the wild and no public exploit code.\n\nAffected product: kubernetes-sigs headlamp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53542/ (Markdown: https://insights.sbomify.com/CVE-2025-53542/index.md)","id":"CVE-2025-53542","markdown":"https://insights.sbomify.com/CVE-2025-53542/index.md","name":"CVE-2025-53542","record":{"aliases":["GHSA-34rf-485x-g5h7"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Kubernetes Headlamp","requires_auth":"none","summary":"An attacker can execute arbitrary commands on macOS via unsanitized environment variables in the Headlamp codeSign script.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"},{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Headlamp is an extensible Kubernetes web UI. A command injection vulnerability was discovered in the codeSign.js script used in the macOS packaging workflow of the Kubernetes Headlamp project. This issue arises due to the improper use of Node.js's execSync() function with unsanitized input derived from environment variables, which can be influenced by an attacker. The variables ${teamID}, ${entitlementsPath}, and ${config.app} are dynamically derived from the environment or application config and passed directly to the shell command without proper escaping or argument separation. This exposes the system to command injection if any of the values contain malicious input. This vulnerability is fixed in 0.31.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Kubernetes Headlamp Allows Arbitrary Command Injection in macOS Process headlamp@codeSign","id":"CVE-2025-53542","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":0,"n_references":4,"next":{"headline":"Kestra allows Stored XSS before 0.22","id":"CVE-2025-53543"},"packages":[],"prev":{"headline":"Tuleap is vulnerable to XSS attacks when displaying the children of a parent artifact","id":"CVE-2025-53541"},"products":["headlamp"],"published":"2025-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-10","vendors":["kubernetes-sigs"]},"summary":"An attacker can execute arbitrary commands on macOS via unsanitized environment variables in the Headlamp codeSign script.","url":"https://insights.sbomify.com/CVE-2025-53542/"}