CVE-2025-53543 Kestra allows Stored XSS before 0.22

Medium 4.2 Published Updated

Attackers can inject malicious scripts via error messages in the execution overview, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-53543?

CVE-2025-53543 is a medium-severity cross-site scripting vulnerability in kestra-io kestra, published on 7 Jul 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Kestra is an event-driven orchestration platform. The error message in execution "Overview" tab is vulnerable to stored XSS due to improper handling of HTTP response received. This vulnerability is fixed in 0.22.0.

Weakness: CWE-79

Which versions are affected by CVE-2025-53543?

How do I fix CVE-2025-53543?

No fix has been published for CVE-2025-53543 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-53543 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53543 exists.

Sources

Also known as GHSA-qpj4-4r6r-wvf4.

Is CVE-2025-53543 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free