# CVE-2025-53544: Trilium Notes is Vulnerable to Brute-force Protection Bypass via Initial Sync Seed Retrieval

> Unauthenticated attackers can bypass brute-force protection to guess login passwords in Trilium Notes, potentially leading to account takeover.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Aug 2025
- **Updated:** 5 Aug 2025
- **Also known as:** GHSA-hw5p-ff75-327r

## What is CVE-2025-53544?

CVE-2025-53544 is a high-severity vulnerability in TriliumNext Trilium, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Trilium Notes is an open-source, cross-platform hierarchical note taking application with focus on building large personal knowledge bases. In versions below 0.97.0, a brute-force protection bypass in the initial sync seed retrieval endpoint allows unauthenticated attackers to guess the login password without triggering rate limiting. Trilium is a single-user app without a username requirement, and brute-force protection bypass makes exploitation much more feasible. Multiple features provided by Trilium (e.g. MFA, share notes, custom request handler) indicate that Trilium can be exposed to the internet. This is fixed in version 0.97.0.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2025-53544?


## How do I fix CVE-2025-53544?

No fix has been published for CVE-2025-53544 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-53544 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53544 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53544 and fix it if it is affected.

What it is: CVE-2025-53544 is a high-severity vulnerability in TriliumNext Trilium, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53544 exists.

Affected product: TriliumNext Trilium. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53544/ (Markdown: https://insights.sbomify.com/CVE-2025-53544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53544
- OSV: https://osv.dev/vulnerability/CVE-2025-53544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53544/
Summaries are generated and may contain mistakes; the official description above is the record.
