CVE-2025-53547 Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2025-53547?
CVE-2025-53547 is a high-severity vulnerability in helm, published on 8 Jul 2025.
Official description
Helm is a package manager for Charts for Kubernetes. Prior to 3.18.4, a specially crafted Chart.yaml file along with a specially linked Chart.lock file can lead to local code execution when dependencies are updated. Fields in a Chart.yaml file, that are carried over to a Chart.lock file when dependencies are updated and this file is written, can be crafted in a way that can cause execution if that same content were in a file that is executed (e.g., a bash.rc file or shell script). If the Chart.lock file is symlinked to one of these files updating dependencies will write the lock file content to the symlinked file. This can lead to unwanted execution. Helm warns of the symlinked file but did not stop execution due to symlinking. This issue has been resolved in Helm v3.18.4.
Weakness: CWE-94
Which versions are affected by CVE-2025-53547?
6 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
helm.sh/helm/v3 Go | All versions | 3.17.4 |
helm.sh/helm/v3 Go | All versions | 3.17.4 |
helm.sh/helm/v3 Go | All versions | 3.18.4 |
helm.sh/helm/v3 Go | From 3.18.0-rc.1 | 3.18.4 |
helm.sh/helm/v3 Go | From 3.18.0-rc.1 | 3.18.4 |
helm Bitnami | All versions | 3.18.4 |
Linux distribution packages (6)
helm SUSE:Linux Micro 6.1 | All versions | 3.18.4-slfo.1.1_1.1 |
cmctl openSUSE:Tumbleweed | All versions | 2.3.0-1.1 |
helm openSUSE:Tumbleweed | All versions | 3.18.4-1.1 |
k9s openSUSE:Tumbleweed | All versions | 0.50.7-2.1 |
kubeshark-cli openSUSE:Tumbleweed | All versions | 52.8.0-1.1 |
trivy openSUSE:Tumbleweed | All versions | 0.64.1-1.1 |
Products include Helm Helm.
How do I fix CVE-2025-53547?
Upgrade helm.sh/helm/v3 to a fixed version for your release line: 3.17.4 or 3.18.4.
Is CVE-2025-53547 being exploited?
There is no known exploitation of CVE-2025-53547 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in helm
- CVE-2019-18658 Helm Unsafe Link Following
- CVE-2019-1010275 Helm Improper Certificate Validation
- CVE-2019-25210 Information disclosure in n/a
- CVE-2020-11013 lookup Function Information Discolosure in Helm
- CVE-2026-35204 Helm has a path traversal in plugin metadata version enables arbitrary file write outside Helm plugin directory
Sources
Also known as AZL-64877, BIT-helm-2025-53547, CLEANSTART-2026-KY23240, CLEANSTART-2026-OG27533, CLEANSTART-2026-PS05327, ECHO-e296-545c-be59 and 25 more.