# CVE-2025-53547: Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution


- **Severity:** High 8.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Jul 2025
- **Updated:** 26 Feb 2026
- **Also known as:** AZL-64877, BIT-helm-2025-53547, CLEANSTART-2026-KY23240, CLEANSTART-2026-OG27533, CLEANSTART-2026-PS05327, ECHO-e296-545c-be59, GHSA-557j-xg8c-q2mm, GO-2025-3802, MINI-559p-rmfh-mx66, MINI-6cfh-qfgc-3chh, MINI-86mp-p943-56v6, MINI-fjh2-m992-m6fx, MINI-fmcg-h896-9gxr, MINI-hcp2-x9jq-4m9r, MINI-j3gx-66j6-28r5, MINI-jfhc-r34g-496x, MINI-jg49-cw3v-pc34, MINI-jggr-2452-8ffh, MINI-q3rc-mw86-xqg6, MINI-q3xr-6w4w-wh29, MINI-q5vw-j33p-7rw7, MINI-q5wh-g97j-w4wm, MINI-rg88-wrhv-xp72, MINI-xp83-fj52-97cj, MINI-xqpr-73p7-6xxf, SUSE-SU-2025:20595-1, openSUSE-SU-2025:15331-1, openSUSE-SU-2025:15336-1, openSUSE-SU-2025:15338-1, openSUSE-SU-2025:15341-1, openSUSE-SU-2025:15406-1

## What is CVE-2025-53547?

CVE-2025-53547 is a high-severity vulnerability in helm, published on 8 Jul 2025. 

### Official description

Helm is a package manager for Charts for Kubernetes. Prior to 3.18.4, a specially crafted Chart.yaml file along with a specially linked Chart.lock file can lead to local code execution when dependencies are updated. Fields in a Chart.yaml file, that are carried over to a Chart.lock file when dependencies are updated and this file is written, can be crafted in a way that can cause execution if that same content were in a file that is executed (e.g., a bash.rc file or shell script). If the Chart.lock file is symlinked to one of these files updating dependencies will write the lock file content to the symlinked file. This can lead to unwanted execution. Helm warns of the symlinked file but did not stop execution due to symlinking. This issue has been resolved in Helm v3.18.4.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-53547?

6 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm/v3` | Go | All versions | 3.17.4 |
| `helm.sh/helm/v3` | Go | All versions | 3.17.4 |
| `helm.sh/helm/v3` | Go | All versions | 3.18.4 |
| `helm.sh/helm/v3` | Go | From 3.18.0-rc.1 | 3.18.4 |
| `helm.sh/helm/v3` | Go | From 3.18.0-rc.1 | 3.18.4 |
| `helm` | Bitnami | All versions | 3.18.4 |
| `helm` | SUSE:Linux Micro 6.1 | All versions | 3.18.4-slfo.1.1_1.1 |
| `cmctl` | openSUSE:Tumbleweed | All versions | 2.3.0-1.1 |
| `helm` | openSUSE:Tumbleweed | All versions | 3.18.4-1.1 |
| `k9s` | openSUSE:Tumbleweed | All versions | 0.50.7-2.1 |
| `kubeshark-cli` | openSUSE:Tumbleweed | All versions | 52.8.0-1.1 |
| `trivy` | openSUSE:Tumbleweed | All versions | 0.64.1-1.1 |

Products: Helm Helm.

## How do I fix CVE-2025-53547?

Upgrade helm.sh/helm/v3 to a fixed version for your release line: 3.17.4 or 3.18.4.

## Is CVE-2025-53547 being exploited?

There is no known exploitation of CVE-2025-53547 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-53547 one of poc code (github_poc): https://github.com/DVKunion/CVE-2025-53547-POC

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)
- [CVE-2026-35204](https://insights.sbomify.com/CVE-2026-35204/): Helm has a path traversal in plugin metadata version enables arbitrary file write outside Helm plugin directory (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53547 and fix it if it is affected.

What it is: CVE-2025-53547 is a high-severity vulnerability in helm, published on 8 Jul 2025. 
Exploitation: There is no known exploitation of CVE-2025-53547 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.17.4
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.17.4
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.18.4
- helm.sh/helm/v3 (Go): affected from 3.18.0-rc.1; fixed in 3.18.4
- helm.sh/helm/v3 (Go): affected from 3.18.0-rc.1; fixed in 3.18.4
- helm (Bitnami): affected all versions; fixed in 3.18.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53547/ (Markdown: https://insights.sbomify.com/CVE-2025-53547/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53547
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53547
- OSV: https://osv.dev/vulnerability/CVE-2025-53547

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53547/
Summaries are generated and may contain mistakes; the official description above is the record.
