# CVE-2025-53548: @clerk/backend Performs Insufficient Verification of Data Authenticity

> Attackers can bypass webhook signature verification in Clerk backend applications, allowing them to inject fake events. Developers using verifyWebhook() must upgrade.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2025
- **Updated:** 9 Jul 2025
- **Also known as:** GHSA-9mp4-77wg-rwx9

## What is CVE-2025-53548?

CVE-2025-53548 is a high-severity vulnerability in clerk javascript, published on 9 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Clerk helps developers build user management. Applications that use the verifyWebhook() helper to verify incoming Clerk webhooks are susceptible to accepting improperly signed webhook events. The issue was resolved in @clerk/backend 2.4.0.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2025-53548?

18 open source packages ship an affected version, including @clerk/astro, @clerk/backend and @clerk/express.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@clerk/astro` | npm | From 2.9.0 | 2.10.2 |
| `@clerk/astro` | npm | From 2.9.0 | 2.10.2 |
| `@clerk/backend` | npm | From 2.0.0 | 2.4.0 |
| `@clerk/backend` | npm | From 2.0.0 | 2.4.0 |
| `@clerk/express` | npm | From 1.6.0 | 1.7.4 |
| `@clerk/express` | npm | From 1.6.0 | 1.7.4 |
| `@clerk/fastify` | npm | From 2.3.0 | 2.4.4 |
| `@clerk/fastify` | npm | From 2.3.0 | 2.4.4 |
| `@clerk/nextjs` | npm | From 6.2.10 | 6.23.3 |
| `@clerk/nextjs` | npm | From 6.2.10 | 6.23.3 |
| `@clerk/nuxt` | npm | From 1.7.0 | 1.7.5 |
| `@clerk/nuxt` | npm | From 1.7.0 | 1.7.5 |
| `@clerk/react-router` | npm | From 1.5.0 | 1.6.4 |
| `@clerk/react-router` | npm | From 1.5.0 | 1.6.4 |
| `@clerk/remix` | npm | From 4.8.0 | 4.8.5 |
| `@clerk/remix` | npm | From 4.8.0 | 4.8.5 |
| `@clerk/tanstack-react-start` | npm | From 0.16.0 | 0.18.3 |
| `@clerk/tanstack-react-start` | npm | From 0.16.0 | 0.18.3 |

## How do I fix CVE-2025-53548?

Upgrade @clerk/astro to 2.10.2 or later.

## Is CVE-2025-53548 being exploited?

There is no known exploitation of CVE-2025-53548 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53548 and fix it if it is affected.

What it is: CVE-2025-53548 is a high-severity vulnerability in clerk javascript, published on 9 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53548 in the wild and no public exploit code.

Affected packages and fixed versions:
- @clerk/astro (npm): affected from 2.9.0; fixed in 2.10.2
- @clerk/astro (npm): affected from 2.9.0; fixed in 2.10.2
- @clerk/backend (npm): affected from 2.0.0; fixed in 2.4.0
- @clerk/backend (npm): affected from 2.0.0; fixed in 2.4.0
- @clerk/express (npm): affected from 1.6.0; fixed in 1.7.4
- @clerk/express (npm): affected from 1.6.0; fixed in 1.7.4
- @clerk/fastify (npm): affected from 2.3.0; fixed in 2.4.4
- @clerk/fastify (npm): affected from 2.3.0; fixed in 2.4.4
- @clerk/nextjs (npm): affected from 6.2.10; fixed in 6.23.3
- @clerk/nextjs (npm): affected from 6.2.10; fixed in 6.23.3
- @clerk/nuxt (npm): affected from 1.7.0; fixed in 1.7.5
- @clerk/nuxt (npm): affected from 1.7.0; fixed in 1.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53548/ (Markdown: https://insights.sbomify.com/CVE-2025-53548/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53548
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53548
- OSV: https://osv.dev/vulnerability/CVE-2025-53548

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53548/
Summaries are generated and may contain mistakes; the official description above is the record.
