# CVE-2025-53549: Matrix Rust SDK allows SQL injection in the EventCache implementation

> Malicious room members can execute arbitrary SQL commands in Matrix clients using the Matrix Rust SDK via the EventCache implementation.

- **Severity:** Medium 5.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2025
- **Updated:** 10 Jul 2025
- **Also known as:** GHSA-275g-g844-73jh, RUSTSEC-2025-0043, openSUSE-SU-2025:15351-1

## What is CVE-2025-53549?

CVE-2025-53549 is a medium-severity SQL injection vulnerability in matrix-org matrix-rust-sdk, published on 10 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Matrix Rust SDK is a collection of libraries that make it easier to build Matrix clients in Rust. An SQL injection vulnerability in the EventCache::find_event_with_relations method of matrix-sdk 0.11 and 0.12 allows malicious room members to execute arbitrary SQL commands in Matrix clients that directly pass relation types provided by those room members into this method, when used with the default sqlite-based store backend. Exploitation is unlikely, as no known clients currently use the API in this manner. This vulnerability is fixed in 0.13.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-53549?

5 open source packages ship an affected version, including matrix-sdk-sqlite and matrix-sdk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-sdk-sqlite` | crates.io | From 0.11.0 | 0.13.0 |
| `matrix-sdk-sqlite` | crates.io | From 0.11.0 | 0.13.0 |
| `matrix-sdk-sqlite` | crates.io | From 0.11.0 | 0.13.0 |
| `matrix-sdk` | crates.io | From 0.11.0 | 0.13.0 |
| `matrix-sdk` | crates.io | From 0.11.0 | 0.13.0 |
| `fractal` | openSUSE:Tumbleweed | All versions | 12.beta+14-1.1 |

## How do I fix CVE-2025-53549?

Upgrade matrix-sdk-sqlite to 0.13.0 or later.

## Is CVE-2025-53549 being exploited?

There is no known exploitation of CVE-2025-53549 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53549 and fix it if it is affected.

What it is: CVE-2025-53549 is a medium-severity SQL injection vulnerability in matrix-org matrix-rust-sdk, published on 10 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53549 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-sdk-sqlite (crates.io): affected from 0.11.0; fixed in 0.13.0
- matrix-sdk-sqlite (crates.io): affected from 0.11.0; fixed in 0.13.0
- matrix-sdk-sqlite (crates.io): affected from 0.11.0; fixed in 0.13.0
- matrix-sdk (crates.io): affected from 0.11.0; fixed in 0.13.0
- matrix-sdk (crates.io): affected from 0.11.0; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53549/ (Markdown: https://insights.sbomify.com/CVE-2025-53549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53549
- OSV: https://osv.dev/vulnerability/CVE-2025-53549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53549/
Summaries are generated and may contain mistakes; the official description above is the record.
