CVE-2025-53606 Apache Seata (incubating): Deserialization of untrusted Data in Apache Seata Server

Critical 9.8 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-53606?

CVE-2025-53606 is a critical vulnerability in Apache Seata (incubating), published on 8 Aug 2025.

Official description

Deserialization of Untrusted Data vulnerability in Apache Seata (incubating).

This issue affects Apache Seata (incubating): 2.4.0.

Users are recommended to upgrade to version 2.5.0, which fixes the issue.

Weakness: CWE-502

Which versions are affected by CVE-2025-53606?

2 open source packages ship an affected version, including org.apache.seata:seata-serializer-fury. It affects 1 product.

PackageAffectedFixed in
org.apache.seata:seata-serializer-fury MavenFrom 2.4.02.5.0
org.apache.seata:seata-serializer-fury MavenFrom 2.4.02.5.0

Products include Apache Seata.

How do I fix CVE-2025-53606?

Upgrade org.apache.seata:seata-serializer-fury to 2.5.0 or later.

Is CVE-2025-53606 being exploited?

There is no known exploitation of CVE-2025-53606 in the wild and no public exploit code.

Sources

Also known as GHSA-g358-g2pq-c46j.

Is CVE-2025-53606 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free