# CVE-2025-53620: Crashing any Qwik Server

> An attacker can crash the Qwik server by sending an invalid server action QRL, causing a Node.js process exit.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2025
- **Updated:** 9 Jul 2025
- **Also known as:** GHSA-qr9h-j6xg-2j72

## What is CVE-2025-53620?

CVE-2025-53620 is a critical denial of service vulnerability in QwikDev qwik, published on 9 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@builder.io/qwik-city is the meta-framework for Qwik. When a Qwik Server Action QRL is executed it dynamically load the file containing the symbol. When an invalid qfunc is sent, the server does not handle the thrown error. The error then causes Node JS to exit. This vulnerability is fixed in 1.13.0.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-53620?

2 open source packages ship an affected version, including @builder.io/qwik-city.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@builder.io/qwik-city` | npm | All versions | 1.13.0 |
| `@builder.io/qwik-city` | npm | All versions | 1.13.0 |

## How do I fix CVE-2025-53620?

Upgrade @builder.io/qwik-city to 1.13.0 or later.

## Is CVE-2025-53620 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53620 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53620 and fix it if it is affected.

What it is: CVE-2025-53620 is a critical denial of service vulnerability in QwikDev qwik, published on 9 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53620 exists.

Affected packages and fixed versions:
- @builder.io/qwik-city (npm): affected all versions; fixed in 1.13.0
- @builder.io/qwik-city (npm): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53620/ (Markdown: https://insights.sbomify.com/CVE-2025-53620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53620
- OSV: https://osv.dev/vulnerability/CVE-2025-53620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53620/
Summaries are generated and may contain mistakes; the official description above is the record.
