{"answers":{"affected":"6 open source packages ship an affected version, including org.dspace:dspace-api.","exploited":"There is no known exploitation of CVE-2025-53622 in the wild and no public exploit code.","fix":"Upgrade org.dspace:dspace-api to a fixed version for your release line: 7.6.4, 8.2 or 9.1.","what":"CVE-2025-53622 is a medium-severity path traversal vulnerability in DSpace, published on 15 Jul 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-53622 and fix it if it is affected.\n\nWhat it is: CVE-2025-53622 is a medium-severity path traversal vulnerability in DSpace, published on 15 Jul 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-53622 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.dspace:dspace-api (Maven): affected all versions; fixed in 7.6.4\n- org.dspace:dspace-api (Maven): affected all versions; fixed in 7.6.4\n- org.dspace:dspace-api (Maven): affected from 8.0; fixed in 8.2\n- org.dspace:dspace-api (Maven): affected from 8.0; fixed in 8.2\n- org.dspace:dspace-api (Maven): affected from 9.0; fixed in 9.1\n- org.dspace:dspace-api (Maven): affected from 9.0; fixed in 9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53622/ (Markdown: https://insights.sbomify.com/CVE-2025-53622/index.md)","id":"CVE-2025-53622","markdown":"https://insights.sbomify.com/CVE-2025-53622/index.md","name":"CVE-2025-53622","record":{"aliases":["GHSA-vhvx-8xgc-99wf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"DSpace repository application","requires_auth":"high_privilege","summary":"An attacker can trick an administrator into importing a malicious archive to read arbitrary server files via path traversal in DSpace.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"DSpace open source software is a repository application which provides durable access to digital resources. Prior to versions 7.6.4, 8.2, and 9.1, a path traversal vulnerability is possible during the import of an archive (in Simple Archive Format), either from command-line (`./dspace import` command) or from the \"Batch Import (Zip)\" user interface feature. An attacker may craft a malicious Simple Archive Format (SAF) package where the `contents` file references any system files (using relative traversal sequences) which are readable by the Tomcat user.  If such a package is imported, this will result in sensitive content disclose, including retrieving arbitrary files or configurations from the server where DSpace is running. The Simple Archive Format (SAF) importer / Batch Import (Zip) is only usable by site administrators (from user interface / REST API) or system administrators (from command-line). Therefore, to exploit this vulnerability, the malicious payload would have to be provided by an attacker and trusted by an administrator (who would trigger the import). The fix is included in DSpace 7.6.4, 8.2 and 9.1. For those who cannot upgrade immediately, it is possible to manually patch the DSpace backend. (No changes are necessary to the frontend.)  A pull request exists which can be used to patch systems running DSpace 7.6.x, 8.x or 9.0. Although it is not possible to fully protect the system via workarounds, one may can apply a best practice. Administrators must carefully inspect any SAF archives (they did not construct themselves) before importing, paying close attention to the `contents` file to validate it does not reference files outside of the SAF archives.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DSpace has path traversal vulnerability in Simple Archive Format (SAF) package import via contents file","id":"CVE-2025-53622","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":6,"n_references":7,"next":{"headline":"Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class","id":"CVE-2025-53623"},"packages":[{"ecosystem":"Maven","fixed":["7.6.4"],"introduced":["0"],"last_affected":[],"package":"org.dspace:dspace-api","purl":null,"source":"GHSA-vhvx-8xgc-99wf"},{"ecosystem":"Maven","fixed":["7.6.4"],"introduced":["0"],"last_affected":[],"package":"org.dspace:dspace-api","purl":"pkg:maven/org.dspace/dspace-api","source":"GHSA-vhvx-8xgc-99wf"},{"ecosystem":"Maven","fixed":["8.2"],"introduced":["8.0"],"last_affected":[],"package":"org.dspace:dspace-api","purl":null,"source":"GHSA-vhvx-8xgc-99wf"},{"ecosystem":"Maven","fixed":["8.2"],"introduced":["8.0"],"last_affected":[],"package":"org.dspace:dspace-api","purl":"pkg:maven/org.dspace/dspace-api","source":"GHSA-vhvx-8xgc-99wf"},{"ecosystem":"Maven","fixed":["9.1"],"introduced":["9.0"],"last_affected":[],"package":"org.dspace:dspace-api","purl":null,"source":"GHSA-vhvx-8xgc-99wf"},{"ecosystem":"Maven","fixed":["9.1"],"introduced":["9.0"],"last_affected":[],"package":"org.dspace:dspace-api","purl":"pkg:maven/org.dspace/dspace-api","source":"GHSA-vhvx-8xgc-99wf"}],"prev":{"headline":"DSpace is vulnerable to XML External Entity injection during archive imports","id":"CVE-2025-53621"},"products":["DSpace"],"published":"2025-07-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-15","vendors":["DSpace"]},"summary":"An attacker can trick an administrator into importing a malicious archive to read arbitrary server files via path traversal in DSpace.","url":"https://insights.sbomify.com/CVE-2025-53622/"}