{"answers":{"affected":"2 open source packages ship an affected version, including job-iteration.","exploited":"There is no known exploitation of CVE-2025-53623 in the wild and no public exploit code.","fix":"Upgrade job-iteration to 1.11 or later.","what":"CVE-2025-53623 is a high-severity command injection vulnerability in Shopify job-iteration, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53623 and fix it if it is affected.\n\nWhat it is: CVE-2025-53623 is a high-severity command injection vulnerability in Shopify job-iteration, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-53623 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- job-iteration (RubyGems): affected all versions; fixed in 1.11\n- job-iteration (RubyGems): affected all versions; fixed in 1.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53623/ (Markdown: https://insights.sbomify.com/CVE-2025-53623/index.md)","id":"CVE-2025-53623","markdown":"https://insights.sbomify.com/CVE-2025-53623/index.md","name":"CVE-2025-53623","record":{"aliases":["GHSA-6qjf-g333-pv38"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby job iteration library","requires_auth":"none","summary":"Attackers can execute arbitrary OS commands via the CsvEnumerator class in the Job Iteration API, leading to system compromise.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The Job Iteration API is an an extension for ActiveJob that make jobs interruptible and resumable Versions prior to 1.11.0 have an arbitrary code execution vulnerability in the `CsvEnumerator` class. This vulnerability can be exploited by an attacker to execute arbitrary commands on the system where the application is running, potentially leading to unauthorized access, data leakage, or complete system compromise. The issue is fixed in versions `1.11.0` and above. Users can mitigate the risk by avoiding the use of untrusted input in the `CsvEnumerator` class and ensuring that any file paths are properly sanitized and validated before being passed to the class methods. Users should avoid using the `count_of_rows_in_file` method with untrusted CSV filenames.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class","id":"CVE-2025-53623","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"docusaurus-plugin-content-gists Exposes GitHub Personal Access Token","id":"CVE-2025-53624"},"packages":[{"ecosystem":"RubyGems","fixed":["1.11"],"introduced":["0"],"last_affected":[],"package":"job-iteration","purl":null,"source":"GHSA-6qjf-g333-pv38"},{"ecosystem":"RubyGems","fixed":["1.11"],"introduced":["0"],"last_affected":[],"package":"job-iteration","purl":"pkg:gem/job-iteration","source":"GHSA-6qjf-g333-pv38"}],"prev":{"headline":"DSpace has path traversal vulnerability in Simple Archive Format (SAF) package import via contents file","id":"CVE-2025-53622"},"products":["job-iteration"],"published":"2025-07-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-15","vendors":["Shopify"]},"summary":"Attackers can execute arbitrary OS commands via the CsvEnumerator class in the Job Iteration API, leading to system compromise.","url":"https://insights.sbomify.com/CVE-2025-53623/"}