# CVE-2025-53623: Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class

> Attackers can execute arbitrary OS commands via the CsvEnumerator class in the Job Iteration API, leading to system compromise.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2025
- **Updated:** 15 Jul 2025
- **Also known as:** GHSA-6qjf-g333-pv38

## What is CVE-2025-53623?

CVE-2025-53623 is a high-severity command injection vulnerability in Shopify job-iteration, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Job Iteration API is an an extension for ActiveJob that make jobs interruptible and resumable Versions prior to 1.11.0 have an arbitrary code execution vulnerability in the `CsvEnumerator` class. This vulnerability can be exploited by an attacker to execute arbitrary commands on the system where the application is running, potentially leading to unauthorized access, data leakage, or complete system compromise. The issue is fixed in versions `1.11.0` and above. Users can mitigate the risk by avoiding the use of untrusted input in the `CsvEnumerator` class and ensuring that any file paths are properly sanitized and validated before being passed to the class methods. Users should avoid using the `count_of_rows_in_file` method with untrusted CSV filenames.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-53623?

2 open source packages ship an affected version, including job-iteration.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `job-iteration` | RubyGems | All versions | 1.11 |
| `job-iteration` | RubyGems | All versions | 1.11 |

## How do I fix CVE-2025-53623?

Upgrade job-iteration to 1.11 or later.

## Is CVE-2025-53623 being exploited?

There is no known exploitation of CVE-2025-53623 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53623 and fix it if it is affected.

What it is: CVE-2025-53623 is a high-severity command injection vulnerability in Shopify job-iteration, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53623 in the wild and no public exploit code.

Affected packages and fixed versions:
- job-iteration (RubyGems): affected all versions; fixed in 1.11
- job-iteration (RubyGems): affected all versions; fixed in 1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53623/ (Markdown: https://insights.sbomify.com/CVE-2025-53623/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53623
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53623
- OSV: https://osv.dev/vulnerability/CVE-2025-53623

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53623/
Summaries are generated and may contain mistakes; the official description above is the record.
