CVE-2025-53626 pdfme has Sandbox Escape and Prototype Pollution vulnerabilities in pdfme expression evaluation
Attackers can execute arbitrary code and modify prototypes via sandbox escape in pdfme's expression evaluation feature.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-53626?
CVE-2025-53626 is a medium-severity code injection vulnerability in pdfme, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
pdfme is a TypeScript-based PDF generator and React-based UI. The expression evaluation feature in pdfme 5.2.0 to 5.4.0 contains critical vulnerabilities allowing sandbox escape leading to XSS and prototype pollution attacks. This vulnerability is fixed in 5.4.1.
Which versions are affected by CVE-2025-53626?
2 open source packages ship an affected version, including @pdfme/common.
| Package | Affected | Fixed in |
|---|---|---|
@pdfme/common npm | From 5.2.0 | 5.4.1 |
@pdfme/common npm | From 5.2.0 | 5.4.1 |
How do I fix CVE-2025-53626?
Upgrade @pdfme/common to 5.4.1 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-53626 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53626 exists.
Sources
Also known as GHSA-54xv-94qv-2gfg.